p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de jupyterhub-ltiauthenticator

Vulnerabilidades publicadas para jupyterhub-ltiauthenticator en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2026-34052

    Media · CVSS 5.9EPSS 0,34%Corrección disponible

    LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)

    LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.

    • Actualiza a 1.6.3
    Publicación Actualización
  2. CVE-2023-25574

    Crítica · CVSS 10EPSS 0,36%Corrección disponible

    JupyterHub's LTI13Authenticator: JWT signature not validated

    `jupyterhub-ltiauthenticator` is a JupyterHub authenticator for learning tools interoperability (LTI). LTI13Authenticator that was introduced in `jupyterhub-ltiauthenticator` 1.3.0 wasn't validating JWT signatures. This is believed to allow the LTI13Authenticator to authorize a forged request. Only users that has configured a JupyterHub installation to use the authenticator class `LTI13Authenticator` are affected. `jupyterhub-ltiauthenticator` version 1.4.0 removes LTI13Authenticator to address the issue. No known workarounds are available.

    • Actualiza a 1.4.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →