p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de jupyterhub-ltiauthenticator

Vulnérabilité publiée pour jupyterhub-ltiauthenticator au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-34052

    Moyenne · CVSS 5.9EPSS 0,34%Correctif disponible

    LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)

    LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.

    • Mettez à jour vers 1.6.3
    Publication Mise à jour
  2. CVE-2023-25574

    Critique · CVSS 10EPSS 0,36%Correctif disponible

    JupyterHub's LTI13Authenticator: JWT signature not validated

    `jupyterhub-ltiauthenticator` is a JupyterHub authenticator for learning tools interoperability (LTI). LTI13Authenticator that was introduced in `jupyterhub-ltiauthenticator` 1.3.0 wasn't validating JWT signatures. This is believed to allow the LTI13Authenticator to authorize a forged request. Only users that has configured a JupyterHub installation to use the authenticator class `LTI13Authenticator` are affected. `jupyterhub-ltiauthenticator` version 1.4.0 removes LTI13Authenticator to address the issue. No known workarounds are available.

    • Mettez à jour vers 1.4.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →