p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de redshift-connector

Vulnerabilidades publicadas para redshift-connector en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2026-8838

    Crítica · CVSS 9.3EPSS 0,81%Corrección disponible

    Remote Code Execution via eval() Injection in amazon-redshift-python-driver

    Unsafe use of Python's eval() on server-received data in the vector_in() function in amazon-redshift-python-driver before 2.1.14 allows a rogue server or man-in-the-middle actor to execute arbitrary code on the client. To remediate this issue, users should upgrade to version 2.1.14.

    • Actualiza a 2.1.14
    Publicación Actualización
  2. CVE-2025-5279

    Alta · CVSS 7EPSS 0,31%Corrección disponible

    Issue with Amazon Redshift Python Connector and the BrowserAzureOAuth2CredentialsProvider plugin

    When the Amazon Redshift Python Connector is configured with the BrowserAzureOAuth2CredentialsProvider plugin, the driver skips the SSL certificate validation step for the Identity Provider. An insecure connection could allow an actor to intercept the token exchange process and retrieve an access token. This issue has been addressed in driver version 2.1.7. Users should upgrade to address this issue and ensure any forked or derivative code is patched to incorporate the new fixes.

    • Actualiza a 2.1.7
    Publicación Actualización
  3. CVE-2024-12745

    Alta · CVSS 8.6EPSS 0,53%Corrección disponible

    SQL Injection in the Amazon Redshift Python Connector affecting v2.1.4

    A SQL injection in the Amazon Redshift Python Connector v2.1.4 allows a user to gain escalated privileges via the get_schemas, get_tables, or get_columns Metadata APIs. Users are recommended to upgrade to the driver version 2.1.5 or revert to driver version 2.1.3.

    • Actualiza a 2.1.5
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →