p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de redshift-connector

Vulnérabilité publiée pour redshift-connector au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2026-8838

    Critique · CVSS 9.3EPSS 0,81%Correctif disponible

    Remote Code Execution via eval() Injection in amazon-redshift-python-driver

    Unsafe use of Python's eval() on server-received data in the vector_in() function in amazon-redshift-python-driver before 2.1.14 allows a rogue server or man-in-the-middle actor to execute arbitrary code on the client. To remediate this issue, users should upgrade to version 2.1.14.

    • Mettez à jour vers 2.1.14
    Publication Mise à jour
  2. CVE-2025-5279

    Élevée · CVSS 7EPSS 0,31%Correctif disponible

    Issue with Amazon Redshift Python Connector and the BrowserAzureOAuth2CredentialsProvider plugin

    When the Amazon Redshift Python Connector is configured with the BrowserAzureOAuth2CredentialsProvider plugin, the driver skips the SSL certificate validation step for the Identity Provider. An insecure connection could allow an actor to intercept the token exchange process and retrieve an access token. This issue has been addressed in driver version 2.1.7. Users should upgrade to address this issue and ensure any forked or derivative code is patched to incorporate the new fixes.

    • Mettez à jour vers 2.1.7
    Publication Mise à jour
  3. CVE-2024-12745

    Élevée · CVSS 8.6EPSS 0,53%Correctif disponible

    SQL Injection in the Amazon Redshift Python Connector affecting v2.1.4

    A SQL injection in the Amazon Redshift Python Connector v2.1.4 allows a user to gain escalated privileges via the get_schemas, get_tables, or get_columns Metadata APIs. Users are recommended to upgrade to the driver version 2.1.5 or revert to driver version 2.1.3.

    • Mettez à jour vers 2.1.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →