SUSE-SU-2024:1269-1
SUSE-SU-2024:1269-1 · Security update for webkit2gtk3
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
This update for webkit2gtk3 fixes the following issues: - CVE-2024-23252: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2024-23254: Fixed possible audio data exilftration cross-origin via malicious website (bsc#1222010). - CVE-2024-23263: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2024-23280: Fixed possible user fingeprint via malicious crafted web content (bsc#1222010). - CVE-2024-23284: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2023-42950: Fixed arbitrary code execution via crafted web content (bsc#1222010). - CVE-2023-42956: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2023-42843: Fixed address bar spoofing via malicious website (bsc#1222010). Other fixes: - Update to version 2.44.0 (bsc#1222010): + Make the DOM accessibility tree reachable from UI process with GTK4. + Removed the X11 and WPE renderers in favor of DMA-BUF. + Improved vblank synchronization when rendering. + Removed key event reinjection in GTK4 to make keyboard shortcuts work in web sites. + Fix gamepads detection by correctly handling focused window in GTK4.
Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0-150200.107.1
Actualiza a 2.44.0-150200.107.1
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0-150200.107.1
Actualiza a 2.44.0-150200.107.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0-150200.107.1
Actualiza a 2.44.0-150200.107.1
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0-150200.107.1
Actualiza a 2.44.0-150200.107.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0-150200.107.1
Actualiza a 2.44.0-150200.107.1
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0-150200.107.1
Actualiza a 2.44.0-150200.107.1
webkit2gtk3 SUSE:Enterprise Storage 7.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0-150200.107.1
Actualiza a 2.44.0-150200.107.1
Fuentes originales
- https://www.suse.com/support/update/announcement/2024/suse-su-20241269-1/
- https://bugzilla.suse.com/1222010
- https://www.suse.com/security/cve/CVE-2023-42843
- https://www.suse.com/security/cve/CVE-2023-42950
- https://www.suse.com/security/cve/CVE-2023-42956
- https://www.suse.com/security/cve/CVE-2024-23252
- https://www.suse.com/security/cve/CVE-2024-23254
- https://www.suse.com/security/cve/CVE-2024-23263
- https://www.suse.com/security/cve/CVE-2024-23280
- https://www.suse.com/security/cve/CVE-2024-23284
- https://osv.dev/vulnerability/SUSE-SU-2024:1269-1