p PatchFirst

SUSE-SU-2024:1269-1

SUSE-SU-2024:1269-1 · Security update for webkit2gtk3

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

This update for webkit2gtk3 fixes the following issues: - CVE-2024-23252: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2024-23254: Fixed possible audio data exilftration cross-origin via malicious website (bsc#1222010). - CVE-2024-23263: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2024-23280: Fixed possible user fingeprint via malicious crafted web content (bsc#1222010). - CVE-2024-23284: Fixed lack of Content Security Policy enforcing via malicious crafted web content (bsc#1222010). - CVE-2023-42950: Fixed arbitrary code execution via crafted web content (bsc#1222010). - CVE-2023-42956: Fixed denial of service via crafted web content (bsc#1222010). - CVE-2023-42843: Fixed address bar spoofing via malicious website (bsc#1222010). Other fixes: - Update to version 2.44.0 (bsc#1222010): + Make the DOM accessibility tree reachable from UI process with GTK4. + Removed the X11 and WPE renderers in favor of DMA-BUF. + Improved vblank synchronization when rendering. + Removed key event reinjection in GTK4 to make keyboard shortcuts work in web sites. + Fix gamepads detection by correctly handling focused window in GTK4.

Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.44.0-150200.107.1

    Mettez à jour vers 2.44.0-150200.107.1

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.44.0-150200.107.1

    Mettez à jour vers 2.44.0-150200.107.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.44.0-150200.107.1

    Mettez à jour vers 2.44.0-150200.107.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS

    Plages de versions concernées
    • ECOSYSTEM: < 2.44.0-150200.107.1

    Mettez à jour vers 2.44.0-150200.107.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2

    Plages de versions concernées
    • ECOSYSTEM: < 2.44.0-150200.107.1

    Mettez à jour vers 2.44.0-150200.107.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3

    Plages de versions concernées
    • ECOSYSTEM: < 2.44.0-150200.107.1

    Mettez à jour vers 2.44.0-150200.107.1

  • webkit2gtk3 SUSE:Enterprise Storage 7.1

    Plages de versions concernées
    • ECOSYSTEM: < 2.44.0-150200.107.1

    Mettez à jour vers 2.44.0-150200.107.1

Sources originales

Vérifiez votre serveur →