p PatchFirst

SUSE-SU-2026:3047-1

SUSE-SU-2026:3047-1 · Security update for go1.26-openssl

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

This update for go1.26-openssl fixes the following issues - Update to version go1.26.5 (bsc#1255111). - CVE-2026-27145: crypto/x509: split candidate hostname only once (bsc#1267450). - CVE-2026-39822: os: Root escape via symlink plus trailing slash (bsc#1271014). - CVE-2026-42504: mime: quadratic complexity in WordDecoder.DecodeHeader (bsc#1267442). - CVE-2026-42505: crypto/tls: omit PSK in ECH outer client hello (bsc#1271015). - CVE-2026-42507: net/textproto: arbitrary input are included in errors without any escaping (bsc#1267444).

Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

  • go1.26-openssl SUSE:Linux Enterprise Server 15 SP4-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

  • go1.26-openssl SUSE:Linux Enterprise Server 15 SP5-LTSS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

  • go1.26-openssl SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

  • go1.26-openssl SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Actualiza a 1.26.5-150000.1.12.1

Fuentes originales

Comprueba tu servidor →