p PatchFirst

SUSE-SU-2026:3047-1

SUSE-SU-2026:3047-1 · Security update for go1.26-openssl

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for go1.26-openssl fixes the following issues - Update to version go1.26.5 (bsc#1255111). - CVE-2026-27145: crypto/x509: split candidate hostname only once (bsc#1267450). - CVE-2026-39822: os: Root escape via symlink plus trailing slash (bsc#1271014). - CVE-2026-42504: mime: quadratic complexity in WordDecoder.DecodeHeader (bsc#1267442). - CVE-2026-42505: crypto/tls: omit PSK in ECH outer client hello (bsc#1271015). - CVE-2026-42507: net/textproto: arbitrary input are included in errors without any escaping (bsc#1267444).

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

  • go1.26-openssl SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

  • go1.26-openssl SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

  • go1.26-openssl SUSE:Linux Enterprise Server 15 SP5-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

  • go1.26-openssl SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

  • go1.26-openssl SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.26.5-150000.1.12.1

    Auf 1.26.5-150000.1.12.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →