p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ruby2.0 · Página 2

Vulnerabilidades publicadas para ruby2.0 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 38

  1. CVE-2018-1000074

    Alta · CVSS 7.8EPSS 2,88%Corrección disponible

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Actualiza a 2.0.0.484-1ubuntu2.10
    Publicación Actualización
  2. CVE-2018-1000073

    Alta · CVSS 7.5EPSS 4,91%Corrección disponible

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    • Actualiza a 2.0.0.484-1ubuntu2.6
    Publicación Actualización
  3. CVE-2017-17405

    Alta · CVSS 8.8EPSS 73,83%Código de explotación públicoCorrección disponible

    CVE-2017-17405

    Ruby before 2.4.3 allows Net::FTP command injection. Net::FTP#get, getbinaryfile, gettextfile, put, putbinaryfile, and puttextfile use Kernel#open to open a local file. If the localfile argument starts with the "|" pipe character, the command following the pipe character is executed. The default value of localfile is File.basename(remotefile), so malicious FTP servers could cause arbitrary command execution.

    • Actualiza a 2.0.0.484-1ubuntu2.5
    Publicación Actualización
  4. CVE-2017-0903

    Crítica · CVSS 9.8EPSS 15,85%Corrección disponible

    CVE-2017-0903

    RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.

    • Actualiza a 2.0.0.484-1ubuntu2.10
    Publicación Actualización
  5. CVE-2017-10784

    Alta · CVSS 8.8EPSS 16,41%Corrección disponible

    CVE-2017-10784

    The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.

    • Actualiza a 2.0.0.484-1ubuntu2.10
    Publicación Actualización
  6. CVE-2017-0898

    Crítica · CVSS 9.1EPSS 9,72%Corrección disponible

    CVE-2017-0898

    Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

    • Actualiza a 2.0.0.484-1ubuntu2.10
    Publicación Actualización
  7. CVE-2017-14064

    Crítica · CVSS 9.8EPSS 9,45%Corrección disponible

    CVE-2017-14064

    Ruby through 2.2.7, 2.3.x through 2.3.4, and 2.4.x through 2.4.1 can expose arbitrary memory during a JSON.generate call. The issues lies in using strdup in ext/json/ext/generator/generator.c, which will stop after encountering a '\0' byte, returning a pointer to a string of length zero, which is not the length stored in space_len.

    • Actualiza a 2.0.0.484-1ubuntu2.10
    Publicación Actualización
  8. CVE-2016-2339

    Crítica · CVSS 9.8EPSS 5,14%Corrección disponible

    CVE-2016-2339

    An exploitable heap overflow vulnerability exists in the Fiddle::Function.new "initialize" function functionality of Ruby. In Fiddle::Function.new "initialize" heap buffer "arg_types" allocation is made based on args array length. Specially constructed object passed as element of args array can increase this array size after mentioned allocation and cause heap overflow.

    • Actualiza a 2.0.0.484-1ubuntu2.4
    Publicación Actualización
  9. CVE-2015-7551

    Alta · CVSS 8.4EPSS 0,5%Corrección disponible

    CVE-2015-7551

    The Fiddle::Handle implementation in ext/fiddle/handle.c in Ruby before 2.0.0-p648, 2.1 before 2.1.8, and 2.2 before 2.2.4, as distributed in Apple OS X before 10.11.4 and other products, mishandles tainting, which allows context-dependent attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted string, related to the DL module and the libffi library. NOTE: this vulnerability exists because of a CVE-2009-5147 regression.

    • Actualiza a 2.0.0.484-1ubuntu2.4
    Publicación Actualización
  10. CVE-2014-8090

    Sin evaluarEPSS 5,71%Corrección disponible

    CVE-2014-8090

    The REXML parser in Ruby 1.9.x before 1.9.3 patchlevel 551, 2.0.x before 2.0.0 patchlevel 598, and 2.1.x before 2.1.5 allows remote attackers to cause a denial of service (CPU and memory consumption) a crafted XML document containing an empty string in an entity that is used in a large number of nested entity references, aka an XML Entity Expansion (XEE) attack. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-1821 and CVE-2014-8080.

    • Actualiza a 2.0.0.484-1ubuntu2.2
    Publicación Actualización
  11. CVE-2014-4975

    Sin evaluarEPSS 3,46%Corrección disponible

    CVE-2014-4975

    Off-by-one error in the encodes function in pack.c in Ruby 1.9.3 and earlier, and 2.x through 2.1.2, when using certain format string specifiers, allows context-dependent attackers to cause a denial of service (segmentation fault) via vectors that trigger a stack-based buffer overflow.

    • Actualiza a 2.0.0.484-1ubuntu2.1
    Publicación Actualización
  12. CVE-2014-8080

    Sin evaluarEPSS 5,64%Corrección disponible

    CVE-2014-8080

    The REXML parser in Ruby 1.9.x before 1.9.3-p550, 2.0.x before 2.0.0-p594, and 2.1.x before 2.1.4 allows remote attackers to cause a denial of service (memory consumption) via a crafted XML document, aka an XML Entity Expansion (XEE) attack.

    • Actualiza a 2.0.0.484-1ubuntu2.1
    Publicación Actualización
  13. CVE-2013-4164

    Sin evaluarEPSS 34,97%Código de explotación públicoCorrección disponible

    CVE-2013-4164

    Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse.

    • Actualiza a 2.0.0.343-1ubuntu1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →