p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ghostscript · Página 2

Vulnerabilidades publicadas para ghostscript en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 78

  1. CVE-2020-16297

    Media · CVSS 5.5EPSS 2,28%Corrección disponible

    CVE-2020-16297

    A buffer overflow vulnerability in FloydSteinbergDitheringC() in contrib/gdevbjca.c of Artifex Software GhostScript v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.13
    Publicación Actualización
  2. CVE-2020-16296

    Media · CVSS 5.5EPSS 2,05%Corrección disponible

    CVE-2020-16296

    A buffer overflow vulnerability in GetNumWrongData() in contrib/lips4/gdevlips.c of Artifex Software GhostScript from v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.13
    Publicación Actualización
  3. CVE-2020-16293

    Media · CVSS 5.5EPSS 1,77%Corrección disponible

    CVE-2020-16293

    A null pointer dereference vulnerability in compose_group_nonknockout_nonblend_isolated_allmask_common() in base/gxblend.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.13
    Publicación Actualización
  4. CVE-2019-14812

    Alta · CVSS 7.3EPSS 2,47%Corrección disponible

    CVE-2019-14812

    A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.11
    Publicación Actualización
  5. CVE-2019-10216

    Alta · CVSS 7.3EPSS 2,3%Corrección disponible

    CVE-2019-10216

    In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.10
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →