p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ghostscript

Vulnerabilidades publicadas para ghostscript en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 78

  1. CVE-2023-28879

    Crítica · CVSS 9.8EPSS 6,34%Corrección disponible

    CVE-2023-28879

    In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.18
    Publicación Actualización
  2. CVE-2020-27792

    Alta · CVSS 7.1EPSS 0,47%Corrección disponible

    Ghostscript: heap buffer over write vulnerability in ghostscript's lp8000_print_page() in gdevlp8k.c

    A heap-based buffer overwrite vulnerability was found in GhostScript's lp8000_print_page() function in the gdevlp8k.c file. This flaw allows an attacker to trick a user into opening a crafted PDF file, triggering the heap buffer overflow that could lead to memory corruption or a denial of service.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.17
    Publicación Actualización
  3. CVE-2020-27824

    Media · CVSS 5.5EPSS 1,61%Corrección disponible

    CVE-2020-27824

    A flaw was found in OpenJPEG’s encoder in the opj_dwt_calc_explicit_stepsizes() function. This flaw allows an attacker who can supply crafted input to decomposition levels to cause a buffer overflow. The highest threat from this vulnerability is to system availability.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.14
    Publicación Actualización
  4. CVE-2020-27814

    Alta · CVSS 7.8EPSS 2,1%Corrección disponible

    CVE-2020-27814

    A heap-buffer overflow was found in the way openjpeg2 handled certain PNG format files. An attacker could use this flaw to cause an application crash or in some cases execute arbitrary code with the permission of the user running such an application.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.14
    Publicación Actualización
  5. CVE-2020-27845

    Media · CVSS 5.5EPSS 1,52%Corrección disponible

    CVE-2020-27845

    There's a flaw in src/lib/openjp2/pi.c of openjpeg in versions prior to 2.4.0. If an attacker is able to provide untrusted input to openjpeg's conversion/encoding functionality, they could cause an out-of-bounds read. The highest impact of this flaw is to application availability.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.14
    Publicación Actualización
  6. CVE-2020-27843

    Media · CVSS 5.5EPSS 1,77%Corrección disponible

    CVE-2020-27843

    A flaw was found in OpenJPEG in versions prior to 2.4.0. This flaw allows an attacker to provide specially crafted input to the conversion or encoding functionality, causing an out-of-bounds read. The highest threat from this vulnerability is system availability.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.14
    Publicación Actualización
  7. CVE-2020-27842

    Media · CVSS 5.5EPSS 1,52%Corrección disponible

    CVE-2020-27842

    There's a flaw in openjpeg's t2 encoder in versions prior to 2.4.0. An attacker who is able to provide crafted input to be processed by openjpeg could cause a null pointer dereference. The highest impact of this flaw is to application availability.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.14
    Publicación Actualización
  8. CVE-2020-27841

    Media · CVSS 5.5EPSS 1,45%Corrección disponible

    CVE-2020-27841

    There's a flaw in openjpeg in versions prior to 2.4.0 in src/lib/openjp2/pi.c. When an attacker is able to provide crafted input to be processed by the openjpeg encoder, this could cause an out-of-bounds read. The greatest impact from this flaw is to application availability.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.14
    Publicación Actualización
  9. CVE-2020-17538

    Media · CVSS 5.5EPSS 1,93%Corrección disponible

    CVE-2020-17538

    A buffer overflow vulnerability in GetNumSameData() in contrib/lips4/gdevlips.c of Artifex Software GhostScript from v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.13
    Publicación Actualización
  10. CVE-2020-16307

    Media · CVSS 5.5EPSS 1,77%Corrección disponible

    CVE-2020-16307

    A null pointer dereference vulnerability in devices/vector/gdevtxtw.c and psi/zbfont.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted postscript file. This is fixed in v9.51.

    • Actualiza a 9.26~dfsg+0-0ubuntu0.18.04.13
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →