p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ghostscript

Vulnérabilités publiées pour ghostscript au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 78

  1. CVE-2023-28879

    Critique · CVSS 9.8EPSS 6,34%Correctif disponible

    CVE-2023-28879

    In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.18
    Publication Mise à jour
  2. CVE-2020-27792

    Élevée · CVSS 7.1EPSS 0,47%Correctif disponible

    Ghostscript: heap buffer over write vulnerability in ghostscript's lp8000_print_page() in gdevlp8k.c

    A heap-based buffer overwrite vulnerability was found in GhostScript's lp8000_print_page() function in the gdevlp8k.c file. This flaw allows an attacker to trick a user into opening a crafted PDF file, triggering the heap buffer overflow that could lead to memory corruption or a denial of service.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.17
    Publication Mise à jour
  3. CVE-2020-27824

    Moyenne · CVSS 5.5EPSS 1,61%Correctif disponible

    CVE-2020-27824

    A flaw was found in OpenJPEG’s encoder in the opj_dwt_calc_explicit_stepsizes() function. This flaw allows an attacker who can supply crafted input to decomposition levels to cause a buffer overflow. The highest threat from this vulnerability is to system availability.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.14
    Publication Mise à jour
  4. CVE-2020-27814

    Élevée · CVSS 7.8EPSS 2,1%Correctif disponible

    CVE-2020-27814

    A heap-buffer overflow was found in the way openjpeg2 handled certain PNG format files. An attacker could use this flaw to cause an application crash or in some cases execute arbitrary code with the permission of the user running such an application.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.14
    Publication Mise à jour
  5. CVE-2020-27845

    Moyenne · CVSS 5.5EPSS 1,52%Correctif disponible

    CVE-2020-27845

    There's a flaw in src/lib/openjp2/pi.c of openjpeg in versions prior to 2.4.0. If an attacker is able to provide untrusted input to openjpeg's conversion/encoding functionality, they could cause an out-of-bounds read. The highest impact of this flaw is to application availability.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.14
    Publication Mise à jour
  6. CVE-2020-27843

    Moyenne · CVSS 5.5EPSS 1,77%Correctif disponible

    CVE-2020-27843

    A flaw was found in OpenJPEG in versions prior to 2.4.0. This flaw allows an attacker to provide specially crafted input to the conversion or encoding functionality, causing an out-of-bounds read. The highest threat from this vulnerability is system availability.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.14
    Publication Mise à jour
  7. CVE-2020-27842

    Moyenne · CVSS 5.5EPSS 1,52%Correctif disponible

    CVE-2020-27842

    There's a flaw in openjpeg's t2 encoder in versions prior to 2.4.0. An attacker who is able to provide crafted input to be processed by openjpeg could cause a null pointer dereference. The highest impact of this flaw is to application availability.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.14
    Publication Mise à jour
  8. CVE-2020-27841

    Moyenne · CVSS 5.5EPSS 1,45%Correctif disponible

    CVE-2020-27841

    There's a flaw in openjpeg in versions prior to 2.4.0 in src/lib/openjp2/pi.c. When an attacker is able to provide crafted input to be processed by the openjpeg encoder, this could cause an out-of-bounds read. The greatest impact from this flaw is to application availability.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.14
    Publication Mise à jour
  9. CVE-2020-17538

    Moyenne · CVSS 5.5EPSS 1,93%Correctif disponible

    CVE-2020-17538

    A buffer overflow vulnerability in GetNumSameData() in contrib/lips4/gdevlips.c of Artifex Software GhostScript from v9.18 to v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.13
    Publication Mise à jour
  10. CVE-2020-16307

    Moyenne · CVSS 5.5EPSS 1,77%Correctif disponible

    CVE-2020-16307

    A null pointer dereference vulnerability in devices/vector/gdevtxtw.c and psi/zbfont.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted postscript file. This is fixed in v9.51.

    • Mettez à jour vers 9.26~dfsg+0-0ubuntu0.18.04.13
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →