p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de giac

Vulnerabilidades publicadas para giac en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2023-7158

    Alta · CVSS 7.3EPSS 1,23%Sin corrección publicada

    MicroPython objslice.c slice_indices heap-based overflow

    A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

    Publicación Actualización
  2. CVE-2023-7152

    Media · CVSS 5.5EPSS 0,89%Sin corrección publicada

    MicroPython modselect.c poll_set_add_fd use after free

    A vulnerability, which was classified as critical, has been found in MicroPython 1.21.0/1.22.0-preview. Affected by this issue is the function poll_set_add_fd of the file extmod/modselect.c. The manipulation leads to use after free. The exploit has been disclosed to the public and may be used. The patch is identified as 8b24aa36ba978eafc6114b6798b47b7bfecdca26. It is recommended to apply a patch to fix this issue. VDB-249158 is the identifier assigned to this vulnerability.

    Publicación Actualización
  3. CVE-2017-17526

    Alta · CVSS 8.8EPSS 1,22%Sin corrección publicada

    CVE-2017-17526

    Input.cc in Bernard Parisse Giac 1.2.3.57 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →