p PatchFirst

CVE-2023-7158

CVE-2023-7158 · MicroPython objslice.c slice_indices heap-based overflow

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

CVSS 7.3 · Alta · EPSS 1,2%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • micropython

    Versiones
    • 1.13.0: Afectada
    • 1.14.0: Afectada
    • 1.15.0: Afectada
    • 1.16.0: Afectada
    • 1.17.0: Afectada
    • 1.18.0: Afectada
    • 1.19.0: Afectada
    • 1.20.0: Afectada
    • 1.21.0: Afectada

    Sin corrección publicada

  • giac Ubuntu:18.04:LTS

    Versiones
    • 1.2.3.57+dfsg1-2build1
    • 1.2.3.57+dfsg1-2build2
    • 1.2.3.57+dfsg1-2build3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • giac Ubuntu:20.04:LTS

    Versiones
    • 1.4.9.69+dfsg1-2build1
    • 1.5.0.85+dfsg1-2
    • 1.5.0.85+dfsg1-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • giac Ubuntu:22.04:LTS

    Versiones
    • 1.6.0.41+dfsg1-1
    • 1.7.0.39+dfsg2-1build1
    • 1.7.0.39+dfsg2-1build2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • giac Ubuntu:24.04:LTS

    Versiones
    • 1.9.0.35+dfsg2-1.1
    • 1.9.0.59+dfsg2-1
    • 1.9.0.69+dfsg2-1
    • 1.9.0.93+dfsg2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • giac Ubuntu:25.10

    Versiones
    • 1.9.0.93+dfsg2-3build1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • giac Ubuntu:26.10

    Versiones
    • 1.9.0.93+dfsg2-3build2
    • 1.9.0.93+dfsg2-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • giac Ubuntu:26.04:LTS

    Versiones
    • 1.9.0.93+dfsg2-3build1
    • 1.9.0.93+dfsg2-3build2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →