p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de haproxy

Vulnerabilidades publicadas para haproxy en los últimos 30 días: 2. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 11

  1. CVE-2026-110353

    Alta · CVSS 7.5EPSS 0,74%Sin corrección publicada

    CVE-2026-110353

    HAProxy 3.2 before 3.4.6 allows a remote unauthenticated attacker to cause a denial of service (worker-thread CPU exhaustion) via a truncated HTTP/2 PING frame. h2c_handle_ping in src/mux_h2.c does not check for a short read, unlike the other H2 frame handlers. Because the incomplete frame cannot be processed, its data is never consumed, and the H2 multiplexer tasklet is repeatedly woken by that pending data without making progress. The CPU spins until timeout http-request closes the connection, and an attacker opening many such connections can sustain high CPU usage.

    Publicación Actualización
  2. CVE-2026-110354

    Alta · CVSS 7.5EPSS 0,81%Sin corrección publicada

    CVE-2026-110354

    HAProxy 3 before 3.4.6 allows a remote unauthenticated attacker to cause a denial of service (persistent worker-thread CPU exhaustion) via an HTTP/1.1 chunked request. Although the H1 multiplexer drains the request before closing the stream, the parser repeatedly re-processes the same bytes without making progress. The affected thread stays busy at 100% CPU after timeouts expire and after the client disconnects, and repeated requests can consume all worker threads until the process is restarted.

    Publicación Actualización
  3. CVE-2026-55204

    Alta · CVSS 8.7EPSS 0,48%Sin corrección publicada

    HAProxy - NULL Pointer Dereference in hpack_dht_insert Function

    HAProxy through 3.4.0, fixed in commit 9a6d1fe, contains a null pointer dereference vulnerability in hpack_dht_insert() within src/hpack-tbl.c that fails to validate the return value of hpack_dht_defrag() when the memory pool is exhausted. An attacker can trigger HPACK dynamic table insertions under memory pressure to dereference a NULL pointer and crash HAProxy worker processes, causing denial of service.

    Publicación Actualización
  4. CVE-2026-55203

    Crítica · CVSS 9EPSS 0,33%Sin corrección publicada

    HAProxy - Integer Overflow in FCGI Demux Record Length Field

    HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers. When contentLength is 65535 and paddingLength is 1 or more, the drl field wraps to 0, causing incorrect record consumption and allowing malicious FastCGI backends to desynchronize the FCGI framing parser, potentially causing request routing errors, response smuggling, or memory safety issues.

    Publicación Actualización
  5. CVE-2023-45539

    Alta · CVSS 8.2EPSS 1,51%Corrección disponible

    CVE-2023-45539

    HAProxy before 2.8.2 accepts # as part of the URI component, which might allow remote attackers to obtain sensitive information or have unspecified other impact upon misinterpretation of a path_end rule, such as routing index.html#.png to a static server.

    • Actualiza a 2.0.31-0ubuntu0.3
    Publicación Actualización
  6. CVE-2023-40225

    Alta · CVSS 7.2EPSS 2,15%Corrección disponible

    CVE-2023-40225

    HAProxy through 2.0.32, 2.1.x and 2.2.x through 2.2.30, 2.3.x and 2.4.x through 2.4.23, 2.5.x and 2.6.x before 2.6.15, 2.7.x before 2.7.10, and 2.8.x before 2.8.2 forwards empty Content-Length headers, violating RFC 9110 section 8.6. In uncommon cases, an HTTP/1 server behind HAProxy may interpret the payload as an extra request.

    • Actualiza a 2.0.31-0ubuntu0.2
    Publicación Actualización
  7. CVE-2023-0056

    Media · CVSS 6.5EPSS 1,83%Corrección disponible

    CVE-2023-0056

    An uncontrolled resource consumption vulnerability was discovered in HAProxy which could crash the service. This issue could allow an authenticated remote attacker to run a specially crafted malicious server in an OpenShift cluster. The biggest impact is to availability.

    • Actualiza a 2.0.29-0ubuntu1.1
    Publicación Actualización
  8. CVE-2023-25725

    Crítica · CVSS 9.1EPSS 5,45%Corrección disponible

    CVE-2023-25725

    HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.

    • Actualiza a 2.0.29-0ubuntu1.3
    Publicación Actualización
  9. CVE-2022-0711

    Alta · CVSS 7.5EPSS 16,56%Corrección disponible

    CVE-2022-0711

    A flaw was found in the way HAProxy processed HTTP responses containing the "Set-Cookie2" header. This flaw could allow an attacker to send crafted HTTP response packets which lead to an infinite loop, eventually resulting in a denial of service condition. The highest threat from this vulnerability is availability.

    • Actualiza a 2.0.13-2ubuntu0.5
    Publicación Actualización
  10. CVE-2021-40346

    Alta · CVSS 7.5EPSS 58,83%Corrección disponible

    CVE-2021-40346

    An integer overflow exists in HAProxy 2.0 through 2.5 in htx_add_header that can be exploited to perform an HTTP request smuggling attack, allowing an attacker to bypass all configured http-request HAProxy ACLs and possibly other ACLs.

    • Actualiza a 2.0.13-2ubuntu0.3
    Publicación Actualización
  11. CVE-2021-39241

    Media · CVSS 5.3EPSS 1,69%Corrección disponible

    CVE-2021-39241

    An issue was discovered in HAProxy 2.0 before 2.0.24, 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. An HTTP method name may contain a space followed by the name of a protected resource. It is possible that a server would interpret this as a request for that protected resource, such as in the "GET /admin? HTTP/1.1 /static/images HTTP/1.1" example.

    • Actualiza a 2.0.13-2ubuntu0.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →