CVE-2023-25725
CVE-2023-25725
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.
CVSS 9.1 · Crítica · EPSS 5,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · web
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
haproxy Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.8-2
Actualiza a 2.6.8-2
haproxy Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.8-2
Actualiza a 2.6.8-2
haproxy Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.8-2
Actualiza a 2.6.8-2
haproxy Ubuntu:Pro:16.04:LTS
- Versiones
- 1.5.14-1
- 1.5.15-1
- 1.6.2-1
- 1.6.2-2
- 1.6.2-2ubuntu1
- 1.6.2-2ubuntu3
- 1.6.3-1
- 1.6.3-1ubuntu0.1
- 1.6.3-1ubuntu0.2
- 1.6.3-1ubuntu0.3
- 1.6.3-1ubuntu0.3+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.3-1ubuntu0.3+esm2
Actualiza a 1.6.3-1ubuntu0.3+esm2
haproxy Ubuntu:18.04:LTS
- Versiones
- 1.7.9-1ubuntu1
- 1.7.9-1ubuntu2
- 1.8.4-1
- 1.8.7-1
- 1.8.8-1
- 1.8.8-1ubuntu0.1
- 1.8.8-1ubuntu0.2
- 1.8.8-1ubuntu0.3
- 1.8.8-1ubuntu0.4
- 1.8.8-1ubuntu0.6
- 1.8.8-1ubuntu0.7
- 1.8.8-1ubuntu0.8
- 1.8.8-1ubuntu0.9
- 1.8.8-1ubuntu0.10
- 1.8.8-1ubuntu0.11
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.8.8-1ubuntu0.13
Actualiza a 1.8.8-1ubuntu0.13
haproxy Ubuntu:20.04:LTS
- Versiones
- 2.0.5-1
- 2.0.8-1
- 2.0.9-1
- 2.0.10-1
- 2.0.10-1ubuntu1
- 2.0.11-1ubuntu1
- 2.0.12-1ubuntu2
- 2.0.13-1ubuntu2
- 2.0.13-2
- 2.0.13-2ubuntu0.1
- 2.0.13-2ubuntu0.2
- 2.0.13-2ubuntu0.3
- 2.0.13-2ubuntu0.5
- 2.0.29-0ubuntu1
- 2.0.29-0ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.29-0ubuntu1.3
Actualiza a 2.0.29-0ubuntu1.3
haproxy Ubuntu:22.04:LTS
- Versiones
- 2.2.9-2ubuntu2
- 2.4.8-1
- 2.4.8-2ubuntu3
- 2.4.11-1ubuntu1
- 2.4.12-1ubuntu1
- 2.4.12-1ubuntu2
- 2.4.13-1ubuntu1
- 2.4.14-1ubuntu1
- 2.4.18-0ubuntu1
- 2.4.18-0ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.18-0ubuntu1.2
Actualiza a 2.4.18-0ubuntu1.2
Fuentes originales
- https://www.haproxy.org/
- https://git.haproxy.org/?p=haproxy-2.7.git%3Ba=commit%3Bh=a0e561ad7f29ed50c473f5a9da664267b60d1112
- https://lists.debian.org/debian-lts-announce/2023/02/msg00012.html
- https://www.debian.org/security/2023/dsa-5348
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FPTJQHKUEU2PQ7RWFUYAFLAD4STEIKHU/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JM5NCIBTHYDTLPY2UNC4HO2VAHHE6CJG/
- https://nvd.nist.gov/vuln/detail/CVE-2023-25725