UBUNTU-CVE-2026-85495
[pre-authentication global buffer overflow]
PatchFirst · Vulnerabilidades recientes
Vulnerabilidades publicadas para ppp en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.
Vulnerabilidades: 4
[pre-authentication global buffer overflow]
The passprompt plugin in pppd in ppp before 2.5.2 mishandles privileges.
The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.
eap.c in pppd in ppp 2.4.2 through 2.4.8 has an rhostname buffer overflow in the eap_request and eap_response functions.
Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.