p PatchFirst

CVE-2020-15704

CVE-2020-15704 · pppd arbitrary file read information disclosure vulnerability

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

CVSS 5.5 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • ppp

    Versiones
    • ≥ 2.4.5, < 2.4.5-5ubuntu1.4: Afectada; ≥ 2.4.5-5.1ubuntu2.3+esm2: No afectada (custom)
    • ≥ 2.4.7, < 2.4.7-1+2ubuntu1.16.04.3: Afectada; ≥ 2.4.7-2+2ubuntu1.3: No afectada; ≥ 2.4.7-2+4.1ubuntu5.1: No afectada; ≥ 2.4.7-2+4.1ubuntu6: No afectada (custom)

    Actualiza a 2.4.5-5.1ubuntu2.3+esm2; Actualiza a 2.4.7-2+2ubuntu1.3

  • ppp Ubuntu:Pro:14.04:LTS

    Versiones
    • 2.4.5-5.1ubuntu2
    • 2.4.5-5.1ubuntu2.1
    • 2.4.5-5.1ubuntu2.2
    • 2.4.5-5.1ubuntu2.3
    • 2.4.5-5.1ubuntu2.3+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.4.5-5.1ubuntu2.3+esm2

    Actualiza a 2.4.5-5.1ubuntu2.3+esm2

  • ppp Ubuntu:16.04:LTS

    Versiones
    • 2.4.6-3.1ubuntu1
    • 2.4.7-1+1ubuntu1
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+2ubuntu1.16.04.1
    • 2.4.7-1+2ubuntu1.16.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.4.7-1+2ubuntu1.16.04.3

    Actualiza a 2.4.7-1+2ubuntu1.16.04.3

  • ppp Ubuntu:18.04:LTS

    Versiones
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+4ubuntu1
    • 2.4.7-1+4ubuntu3
    • 2.4.7-2+1ubuntu1
    • 2.4.7-2+2ubuntu1
    • 2.4.7-2+2ubuntu1.1
    • 2.4.7-2+2ubuntu1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.4.7-2+2ubuntu1.3

    Actualiza a 2.4.7-2+2ubuntu1.3

  • ppp Ubuntu:20.04:LTS

    Versiones
    • 2.4.7-2+4.1ubuntu4
    • 2.4.7-2+4.1ubuntu5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.4.7-2+4.1ubuntu5.1

    Actualiza a 2.4.7-2+4.1ubuntu5.1

Fuentes originales

Comprueba tu servidor →