p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de jupyterhub

Vulnerabilidad publicada para jupyterhub en los últimos 30 días: 1. En el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 7

  1. CVE-2026-108752

    Baja · CVSS 2.3EPSS 0,24%Sin corrección publicada

    JupyterHub through 6.0.1 OAuth Client ID Collision via Unescaped Hyphen

    JupyterHub through 6.0.1 contains an identifier collision vulnerability that allows authenticated users to overwrite another user's named-server OAuth client by registering a hyphenated username. Attackers holding a name like alice-prod can overwrite the client for alice's server prod, breaking OAuth login and revoking tokens by stopping their own server.

    Publicación Actualización
  2. CVE-2026-54338

    Media · CVSS 5.3EPSS 0,44%Sin corrección publicada

    JupyterHub: Unauthenticated Denial of Service via Unbounded Username Logging on Failed Login

    JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. Prior to 5.5.0, invalid input to form-based login authenticators can place an unbounded attacker-controlled username in failed-login logs, allowing an unauthenticated attacker to consume logging and storage resources. This issue is fixed in version 5.5.0.

    Publicación Actualización
  3. CVE-2026-40864

    Media · CVSS 5.4EPSS 0,15%Sin corrección publicada

    JupyterHub: Cross-origin form POSTs bypass XSRF

    JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. In versions 4.1.0 through 5.4.4, XSRF protection (updated in 4.1.0) inappropriately treated requests with Sec-Fetch-Mode: no-cors as same-origin requests, bypassing XSRF checks. The JSON API is not affected, only HTTP form endpoints, such as /hub/spawn and /hub/accept-share, meaning attackers could trigger server spawn (but not access the server) and if the attacker is a JupyterHub user permitted to share access to their server, cause a user to accept a share and have access to the attacker's server. This issue has been fixed in version 5.4.5. If dev

    Publicación Actualización
  4. CVE-2026-33709

    Media · CVSS 5.1EPSS 0,21%Sin corrección publicada

    JupyterHub has an Open Redirect Vulnerability

    JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to version 5.4.4, an open redirect vulnerability in JupyterHub allows attackers to construct links which, when clicked, take users to the JupyterHub login page, after which they are sent to an arbitrary attacker-controlled site outside JupyterHub instead of a JupyterHub page, bypassing JupyterHub's check to prevent this. This issue has been patched in version 5.4.4.

    Publicación Actualización
  5. CVE-2024-41942

    Alta · CVSS 7.2EPSS 0,59%Sin corrección publicada

    JupyterHub has a privilege escalation vulnerability with the `admin:users` scope

    JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to versions 4.1.6 and 5.1.0, if a user is granted the `admin:users` scope, they may escalate their own privileges by making themselves a full admin user. The impact is relatively small in that `admin:users` is already an extremely privileged scope only granted to trusted users. In effect, `admin:users` is equivalent to `admin=True`, which is not intended. Note that the change here only prevents escalation to the built-in JupyterHub admin role that has unrestricted permissions. It does not prevent users with e.g. `groups` permissions from granting

    Publicación Actualización
  6. CVE-2024-28233

    Alta · CVSS 8.1EPSS 0,33%Sin corrección publicada

    XSS in JupyterHub via Self-XSS leveraged by Cookie Tossing

    JupyterHub is an open source multi-user server for Jupyter notebooks. By tricking a user into visiting a malicious subdomain, the attacker can achieve an XSS directly affecting the former's session. More precisely, in the context of JupyterHub, this XSS could achieve full access to JupyterHub API and user's single-user server. The affected configurations are single-origin JupyterHub deployments and JupyterHub deployments with user-controlled applications running on subdomains or peer subdomains of either the Hub or a single-user server. This vulnerability is fixed in 4.1.0.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →