p PatchFirst

CVE-2026-40864

CVE-2026-40864 · JupyterHub: Cross-origin form POSTs bypass XSRF

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

JupyterHub is software that allows users to create a multi-user server for Jupyter notebooks. In versions 4.1.0 through 5.4.4, XSRF protection (updated in 4.1.0) inappropriately treated requests with Sec-Fetch-Mode: no-cors as same-origin requests, bypassing XSRF checks. The JSON API is not affected, only HTTP form endpoints, such as /hub/spawn and /hub/accept-share, meaning attackers could trigger server spawn (but not access the server) and if the attacker is a JupyterHub user permitted to share access to their server, cause a user to accept a share and have access to the attacker's server. This issue has been fixed in version 5.4.5. If developers are unable to immediately upgrade, they can temporarily mitigate this issue by dropping requests to JupyterHub with Sec-Fetch-Mode: no-cors if they are using a reverse proxy.

CVSS 5.4 · Media · EPSS 0,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • jupyterhub

    Versiones
    • >= 4.1.0, < 5.4.5: Afectada

    Sin corrección publicada

  • jupyterhub Debian:13

    Versiones
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterhub Debian:14

    Versiones
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterhub PyPI

    Versiones
    • 4.1.0
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.1.4
    • 4.1.5
    • 4.1.6
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.1.0
    • 5.2.0
    • 5.2.1
    • 5.3.0
    • 5.3.0rc0
    • 5.4.0
    • 5.4.1
    • 5.4.2
    • 5.4.3
    • 5.4.4
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 4.1.0, < 5.4.5

    Actualiza a 5.4.5

  • jupyterhub Ubuntu:22.04:LTS

    Versiones
    • 2.0.0+ds1-1
    • 2.0.0+ds1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterhub Ubuntu:24.04:LTS

    Versiones
    • 3.0.0+ds1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterhub Ubuntu:25.10

    Versiones
    • 5.2.1+ds1-2
    • 5.2.1+ds1-3
    • 5.2.1+ds1-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterhub Ubuntu:26.10

    Versiones
    • 5.2.1+ds1-4
    • 5.2.1+ds1-5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyterhub Ubuntu:26.04:LTS

    Versiones
    • 5.2.1+ds1-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →