p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de moodle · Página 12

Vulnerabilidades publicadas para moodle en los últimos 30 días: 12. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 323

  1. CVE-2021-21809

    Alta · CVSS 8.2EPSS 24,17%Código de explotación públicoSin corrección publicada

    CVE-2021-21809

    A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10. A specially crafted series of HTTP requests can lead to command execution. An attacker must have administrator privileges to exploit this vulnerabilities.

    Publicación Actualización
  2. CVE-2019-14827

    Media · CVSS 6.1EPSS 0,67%Sin corrección publicada

    CVE-2019-14827

    A vulnerability was found in Moodle where javaScript injection was possible in some Mustache templates via recursive rendering from contexts. Mustache helper tags that were included in template contexts were not being escaped before that context was injected into another Mustache helper, which could result in script injection in some templates. This affects versions 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions.

    Publicación Actualización
  3. CVE-2019-14831

    Media · CVSS 6.1EPSS 0,81%Sin corrección publicada

    CVE-2019-14831

    A vulnerability was found in Moodle 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where forum subscribe link contained an open redirect if forced subscription mode was enabled. If a forum's subscription mode was set to "forced subscription", the forum's subscribe link contained an open redirect.

    Publicación Actualización
  4. CVE-2019-14830

    Media · CVSS 6.1EPSS 3,3%Sin corrección publicada

    CVE-2019-14830

    A vulnerability was found in Moodle 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where the mobile launch endpoint contained an open redirect in some circumstances, which could result in a user's mobile access token being exposed. (Note: This does not affect sites with a forced URL scheme configured, mobile service disabled, or where the mobile app login method is "via the app").

    Publicación Actualización
  5. CVE-2019-14828

    Media · CVSS 4.3EPSS 0,7%Sin corrección publicada

    CVE-2019-14828

    A vulnerability was found in Moodle affecting 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where users with the capability to create courses were assigned as a teacher in those courses, regardless of whether they had the capability to be automatically assigned that role.

    Publicación Actualización
  6. CVE-2021-20185

    Media · CVSS 5.3EPSS 1,39%Sin corrección publicada

    CVE-2021-20185

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

    Publicación Actualización
  7. CVE-2021-20184

    Media · CVSS 4.3EPSS 0,73%Sin corrección publicada

    CVE-2021-20184

    It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.

    Publicación Actualización
  8. CVE-2021-20186

    Media · CVSS 5.4EPSS 0,76%Sin corrección publicada

    CVE-2021-20186

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.

    Publicación Actualización
  9. CVE-2021-20187

    Alta · CVSS 7.2EPSS 1,59%Sin corrección publicada

    CVE-2021-20187

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

    Publicación Actualización
  10. CVE-2020-25629

    Alta · CVSS 8.8EPSS 1,32%Sin corrección publicada

    CVE-2020-25629

    A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →