p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de node-express

Vulnerabilidades publicadas para node-express en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2024-43796

    Media · CVSS 5EPSS 0,49%Corrección disponible

    express vulnerable to XSS via response.redirect()

    Express.js minimalist web framework for node. In express < 4.20.0, passing untrusted user input - even after sanitizing it - to response.redirect() may execute untrusted code. This issue is patched in express 4.20.0.

    • Actualiza a 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
    Publicación Actualización
  2. CVE-2024-29041

    Media · CVSS 6.1EPSS 0,79%Corrección disponible

    Express.js Open Redirect in malformed URLs

    Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method i

    • Actualiza a 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
    Publicación Actualización
  3. CVE-2014-6393

    Media · CVSS 6.1EPSS 1,14%Sin corrección publicada

    CVE-2014-6393

    The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →