CVE-2024-29041
CVE-2024-29041 · Express.js Open Redirect in malformed URLs
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Express.js minimalist web framework for node. Versions of Express.js prior to 4.19.0 and all pre-release alpha and beta versions of 5.0 are affected by an open redirect vulnerability using malformed URLs. When a user of Express performs a redirect using a user-provided URL Express performs an encode [using `encodeurl`](https://github.com/pillarjs/encodeurl) on the contents before passing it to the `location` header. This can cause malformed URLs to be evaluated in unexpected ways by common redirect allow list implementations in Express applications, leading to an Open Redirect via bypass of a properly implemented allow list. The main method impacted is `res.location()` but this is also called from within `res.redirect()`. The vulnerability is fixed in 4.19.2 and 5.0.0-beta.3.
CVSS 6.1 · Media · EPSS 0,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
express
- Versiones
- >=4.14.0, <4.19.0: Afectada
- >=5.0.0-alpha.1, <5.0.0-beta.3: Afectada
Sin corrección publicada
node-express Debian:12
- Versiones
- 4.18.2+~4.17.14-1
- 4.18.2+~cs8.34.50-1
- 4.19.2+~cs8.36.21-1
- 4.19.2+~cs8.36.26-1
- 4.21.0+~cs8.36.26-1
- 4.21.0+~cs8.36.26-2
- 4.21.2+~cs8.36.27-1
- 4.21.2+~cs8.36.27-2
- 4.21.2+~cs8.36.27-3
- 5.1.0+~cs12.3.3-1
- 5.2.1+~cs12.3.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-express Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.19.2+~cs8.36.21-1
Actualiza a 4.19.2+~cs8.36.21-1
node-express Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.19.2+~cs8.36.21-1
Actualiza a 4.19.2+~cs8.36.21-1
express npm
- Intervalos de versiones afectados
- SEMVER: < 4.19.2
Actualiza a 4.19.2
express npm
- Intervalos de versiones afectados
- SEMVER: ≥ 5.0.0-alpha.1, < 5.0.0-beta.3
Actualiza a 5.0.0-beta.3
node-express Ubuntu:Pro:16.04:LTS
- Versiones
- 4.1.1~dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.16.04.1~esm1
Actualiza a 4.1.1~dfsg-1ubuntu0.16.04.1~esm1
node-express Ubuntu:Pro:18.04:LTS
- Versiones
- 4.1.1~dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
Actualiza a 4.1.1~dfsg-1ubuntu0.18.04.1~esm1
node-express Ubuntu:Pro:20.04:LTS
- Versiones
- 4.17.1-1
- 4.17.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.17.1-2ubuntu0.1~esm1
Actualiza a 4.17.1-2ubuntu0.1~esm1
node-express Ubuntu:Pro:22.04:LTS
- Versiones
- 4.17.1-3
- 4.17.1+~cs4.17.13-1
- 4.17.2+~4.17.13-1
- 4.17.3+~4.17.13-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.17.3+~4.17.13-1ubuntu0.1~esm1
Actualiza a 4.17.3+~4.17.13-1ubuntu0.1~esm1
Fuentes originales
- https://github.com/expressjs/express/security/advisories/GHSA-rv95-896h-c2vc
- https://github.com/koajs/koa/issues/1800
- https://github.com/expressjs/express/pull/5539
- https://github.com/expressjs/express/commit/0867302ddbde0e9463d0564fea5861feb708c2dd
- https://github.com/expressjs/express/commit/0b746953c4bd8e377123527db11f9cd866e39f94
- https://expressjs.com/en/4x/api.html#res.location
- https://nvd.nist.gov/vuln/detail/CVE-2024-29041