p PatchFirst

ALPINE-CVE-2025-61594

ALPINE-CVE-2025-61594

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

CVSS 7.5 · Élevée · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • ruby Alpine:v3.20

    Plages de versions concernées
    • ECOSYSTEM: < 3.3.10-r0

    Mettez à jour vers 3.3.10-r0

  • ruby Alpine:v3.21

    Plages de versions concernées
    • ECOSYSTEM: < 3.3.10-r0

    Mettez à jour vers 3.3.10-r0

  • ruby Alpine:v3.22

    Plages de versions concernées
    • ECOSYSTEM: < 3.4.7-r0

    Mettez à jour vers 3.4.7-r0

  • ruby Alpine:v3.23

    Plages de versions concernées
    • ECOSYSTEM: < 3.4.7-r0

    Mettez à jour vers 3.4.7-r0

  • ruby Alpine:v3.24

    Plages de versions concernées
    • ECOSYSTEM: < 3.4.7-r0

    Mettez à jour vers 3.4.7-r0

Sources originales

Vérifiez votre serveur →