p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ruby

Vulnérabilité publiée pour ruby au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 42

  1. ALPINE-CVE-2025-61594

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2025-61594

    URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

    • Mettez à jour vers 3.3.10-r0
    Publication Mise à jour
  2. ALPINE-CVE-2025-27219

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2025-27219

    In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when parsing extremely large cookies.

    • Mettez à jour vers 3.3.8-r0
    Publication Mise à jour
  3. ALPINE-CVE-2024-27282

    Moyenne · CVSS 6.6Correctif disponible

    ALPINE-CVE-2024-27282

    An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

    • Mettez à jour vers 3.3.1-r0
    Publication Mise à jour
  4. ALPINE-CVE-2024-27281

    Moyenne · CVSS 4.5Correctif disponible

    ALPINE-CVE-2024-27281

    An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.

    • Mettez à jour vers 3.3.1-r0
    Publication Mise à jour
  5. ALPINE-CVE-2024-27280

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2024-27280

    A buffer-overread issue was discovered in StringIO 3.0.1, as distributed in Ruby 3.0.x through 3.0.6 and 3.1.x through 3.1.4. The ungetbyte and ungetc methods on a StringIO can read past the end of a string, and a subsequent call to StringIO.gets may return the memory value. 3.0.3 is the main fixed version; however, for Ruby 3.0 users, a fixed version is stringio 3.0.1.1, and for Ruby 3.1 users, a fixed version is stringio 3.0.1.2.

    • Mettez à jour vers 3.3.1-r0
    Publication Mise à jour
  6. ALPINE-CVE-2023-28756

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2023-28756

    A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1. The Time parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to Time objects. The fixed versions are 0.1.1 and 0.2.2.

    • Mettez à jour vers 3.1.4-r0
    Publication Mise à jour
  7. ALPINE-CVE-2023-28755

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2023-28755

    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

    • Mettez à jour vers 3.1.4-r0
    Publication Mise à jour
  8. ALPINE-CVE-2021-33621

    Élevée · CVSS 8.8Correctif disponible

    ALPINE-CVE-2021-33621

    The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

    • Mettez à jour vers 3.1.3-r0
    Publication Mise à jour
  9. ALPINE-CVE-2022-28738

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2022-28738

    A double free was found in the Regexp compiler in Ruby 3.x before 3.0.4 and 3.1.x before 3.1.2. If a victim attempts to create a Regexp from untrusted user input, an attacker may be able to write to unexpected memory locations.

    • Mettez à jour vers 3.1.2-r0
    Publication Mise à jour
  10. ALPINE-CVE-2021-41816

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2021-41816

    CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

    • Mettez à jour vers 3.0.3-r0
    Publication Mise à jour
  11. ALPINE-CVE-2021-32066

    Élevée · CVSS 7.4Correctif disponible

    ALPINE-CVE-2021-32066

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. Net::IMAP does not raise an exception when StartTLS fails with an an unknown response, which might allow man-in-the-middle attackers to bypass the TLS protections by leveraging a network position between the client and the registry to block the StartTLS command, aka a "StartTLS stripping attack."

    • Mettez à jour vers 2.7.4-r0
    Publication Mise à jour
  12. ALPINE-CVE-2021-31810

    Moyenne · CVSS 5.8Correctif disponible

    ALPINE-CVE-2021-31810

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port. This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions).

    • Mettez à jour vers 2.7.4-r0
    Publication Mise à jour
  13. ALPINE-CVE-2020-25613

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2020-25613

    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    • Mettez à jour vers 2.7.2-r0
    Publication Mise à jour
  14. ALPINE-CVE-2020-10933

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2020-10933

    An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

    • Mettez à jour vers 2.6.6-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →