p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ruby

Vulnérabilité publiée pour ruby au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 36

  1. ALPINE-CVE-2023-28756

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2023-28756

    A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1. The Time parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to Time objects. The fixed versions are 0.1.1 and 0.2.2.

    • Mettez à jour vers 2.7.8-r0
    Publication Mise à jour
  2. ALPINE-CVE-2023-28755

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2023-28755

    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

    • Mettez à jour vers 2.7.8-r0
    Publication Mise à jour
  3. ALPINE-CVE-2021-33621

    Élevée · CVSS 8.8Correctif disponible

    ALPINE-CVE-2021-33621

    The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

    • Mettez à jour vers 2.7.7-r0
    Publication Mise à jour
  4. ALPINE-CVE-2021-41816

    Critique · CVSS 9.8Correctif disponible

    ALPINE-CVE-2021-41816

    CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

    • Mettez à jour vers 2.7.5-r0
    Publication Mise à jour
  5. ALPINE-CVE-2021-32066

    Élevée · CVSS 7.4Correctif disponible

    ALPINE-CVE-2021-32066

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. Net::IMAP does not raise an exception when StartTLS fails with an an unknown response, which might allow man-in-the-middle attackers to bypass the TLS protections by leveraging a network position between the client and the registry to block the StartTLS command, aka a "StartTLS stripping attack."

    • Mettez à jour vers 2.7.4-r0
    Publication Mise à jour
  6. ALPINE-CVE-2021-31810

    Moyenne · CVSS 5.8Correctif disponible

    ALPINE-CVE-2021-31810

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port. This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions).

    • Mettez à jour vers 2.7.4-r0
    Publication Mise à jour
  7. ALPINE-CVE-2020-25613

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2020-25613

    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    • Mettez à jour vers 2.7.2-r0
    Publication Mise à jour
  8. ALPINE-CVE-2020-10933

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2020-10933

    An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

    • Mettez à jour vers 2.6.6-r0
    Publication Mise à jour
  9. ALPINE-CVE-2020-10663

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2020-10663

    The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

    • Mettez à jour vers 2.6.6-r0
    Publication Mise à jour
  10. ALPINE-CVE-2019-16255

    Élevée · CVSS 8.1Correctif disponible

    ALPINE-CVE-2019-16255

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

    • Mettez à jour vers 2.6.5-r0
    Publication Mise à jour
  11. ALPINE-CVE-2019-16254

    Moyenne · CVSS 5.3Correctif disponible

    ALPINE-CVE-2019-16254

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

    • Mettez à jour vers 2.6.5-r0
    Publication Mise à jour
  12. ALPINE-CVE-2019-16201

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    • Mettez à jour vers 2.6.5-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →