p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ruby

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ruby: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 36

  1. ALPINE-CVE-2023-28756

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2023-28756

    A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1. The Time parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to Time objects. The fixed versions are 0.1.1 and 0.2.2.

    • Auf 2.7.8-r0 aktualisieren
    Veröffentlicht Aktualisiert
  2. ALPINE-CVE-2023-28755

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2023-28755

    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

    • Auf 2.7.8-r0 aktualisieren
    Veröffentlicht Aktualisiert
  3. ALPINE-CVE-2021-33621

    Hoch · CVSS 8.8Korrektur verfügbar

    ALPINE-CVE-2021-33621

    The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

    • Auf 2.7.7-r0 aktualisieren
    Veröffentlicht Aktualisiert
  4. ALPINE-CVE-2022-28739

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-28739

    There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2. It occurs in String-to-Float conversion, including Kernel#Float and String#to_f.

    • Auf 2.7.6-r0 aktualisieren
    Veröffentlicht Aktualisiert
  5. ALPINE-CVE-2021-41816

    Kritisch · CVSS 9.8Korrektur verfügbar

    ALPINE-CVE-2021-41816

    CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

    • Auf 2.7.5-r0 aktualisieren
    Veröffentlicht Aktualisiert
  6. ALPINE-CVE-2021-32066

    Hoch · CVSS 7.4Korrektur verfügbar

    ALPINE-CVE-2021-32066

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. Net::IMAP does not raise an exception when StartTLS fails with an an unknown response, which might allow man-in-the-middle attackers to bypass the TLS protections by leveraging a network position between the client and the registry to block the StartTLS command, aka a "StartTLS stripping attack."

    • Auf 2.7.4-r0 aktualisieren
    Veröffentlicht Aktualisiert
  7. ALPINE-CVE-2021-31810

    Mittel · CVSS 5.8Korrektur verfügbar

    ALPINE-CVE-2021-31810

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port. This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions).

    • Auf 2.7.4-r0 aktualisieren
    Veröffentlicht Aktualisiert
  8. ALPINE-CVE-2021-28965

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2021-28965

    The REXML gem before 3.2.5 in Ruby before 2.6.7, 2.7.x before 2.7.3, and 3.x before 3.0.1 does not properly address XML round-trip issues. An incorrect document can be produced after parsing and serializing.

    • Auf 2.7.3-r0 aktualisieren
    Veröffentlicht Aktualisiert
  9. ALPINE-CVE-2020-25613

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2020-25613

    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    • Auf 2.7.2-r0 aktualisieren
    Veröffentlicht Aktualisiert
  10. ALPINE-CVE-2020-10933

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2020-10933

    An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

    • Auf 2.6.6-r0 aktualisieren
    Veröffentlicht Aktualisiert
  11. ALPINE-CVE-2020-10663

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2020-10663

    The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

    • Auf 2.6.6-r0 aktualisieren
    Veröffentlicht Aktualisiert
  12. ALPINE-CVE-2019-16255

    Hoch · CVSS 8.1Korrektur verfügbar

    ALPINE-CVE-2019-16255

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

    • Auf 2.6.5-r0 aktualisieren
    Veröffentlicht Aktualisiert
  13. ALPINE-CVE-2019-16254

    Mittel · CVSS 5.3Korrektur verfügbar

    ALPINE-CVE-2019-16254

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

    • Auf 2.6.5-r0 aktualisieren
    Veröffentlicht Aktualisiert
  14. ALPINE-CVE-2019-16201

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    • Auf 2.6.5-r0 aktualisieren
    Veröffentlicht Aktualisiert
  15. ALPINE-CVE-2018-16396

    Hoch · CVSS 8.1Korrektur verfügbar

    ALPINE-CVE-2018-16396

    An issue was discovered in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. It does not taint strings that result from unpacking tainted strings with some formats.

    • Auf 2.5.2-r0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →