p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de lighttpd

Vulnérabilités publiées pour lighttpd au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. ALPINE-CVE-2025-8671

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2025-8671

    A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to denial-of-service (DoS). By opening streams and then rapidly triggering the server to reset them—using malformed frames or flow control errors—an attacker can exploit incorrect stream accounting. Streams reset by the server are considered closed at the protocol level, even though backend processing continues. This allows a client to cause the server to handle an unbounded number of concurrent streams on a single connection. Th

    • Mettez à jour vers 0-r0
    Publication Mise à jour
  2. ALPINE-CVE-2022-41556

    Élevée · CVSS 7.5Correctif disponible

    ALPINE-CVE-2022-41556

    A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

    • Mettez à jour vers 1.4.67-r0
    Publication Mise à jour
  3. ALPINE-CVE-2022-22707

    Moyenne · CVSS 5.9Correctif disponible

    ALPINE-CVE-2022-22707

    In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

    • Mettez à jour vers 1.4.64-r0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →