CVE-2017-3738
CVE-2017-3738
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.
There is an overflow bug in the AVX2 Montgomery multiplication procedure used in exponentiation with 1024-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH1024 are considered just feasible, because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be significant. However, for an attack on TLS to be meaningful, the server would have to share the DH1024 private key among multiple clients, which is no longer an option since CVE-2016-0701. This only affects processors that support the AVX2 but not ADX extensions like Intel Haswell (4th generation). Note: The impact from this issue is similar to CVE-2017-3736, CVE-2017-3732 and CVE-2015-3193. OpenSSL version 1.0.2-1.0.2m and 1.1.0-1.1.0g are affected. Fixed in OpenSSL 1.0.2n. Due to the low severity of this issue we are not issuing a new release of OpenSSL 1.1.0 at this time. The fix will be included in OpenSSL 1.1.0h when it becomes available. The fix is also available in commit e502cc86d in the OpenSSL git repository.
CVSS 5.9 · Moyenne · EPSS 13,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · network
Produits et versions concernés
openssl
- Versions du logiciel
- 1.0.2-1.02m: Concernée
- 1.1.0-1.1.0g: Concernée
Aucun correctif publié
openssl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0h-1
Mettez à jour vers 1.1.0h-1
openssl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0h-1
Mettez à jour vers 1.1.0h-1
openssl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0h-1
Mettez à jour vers 1.1.0h-1
openssl Ubuntu:16.04:LTS
- Versions du logiciel
- 1.0.2d-0ubuntu1
- 1.0.2d-0ubuntu2
- 1.0.2e-1ubuntu1
- 1.0.2f-2ubuntu1
- 1.0.2g-1ubuntu2
- 1.0.2g-1ubuntu3
- 1.0.2g-1ubuntu4
- 1.0.2g-1ubuntu4.1
- 1.0.2g-1ubuntu4.2
- 1.0.2g-1ubuntu4.4
- 1.0.2g-1ubuntu4.5
- 1.0.2g-1ubuntu4.6
- 1.0.2g-1ubuntu4.8
- 1.0.2g-1ubuntu4.9
- Plages de versions concernées
- ECOSYSTEM: < 1.0.2g-1ubuntu4.10
Mettez à jour vers 1.0.2g-1ubuntu4.10
openssl Ubuntu:18.04:LTS
- Versions du logiciel
- 1.0.2g-1ubuntu13
- 1.0.2g-1ubuntu14
- 1.0.2n-1ubuntu1
- 1.1.0g-2ubuntu1
- 1.1.0g-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 1.1.0g-2ubuntu3
Mettez à jour vers 1.1.0g-2ubuntu3
Sources originales
- https://www.tenable.com/security/tns-2018-07
- https://www.tenable.com/security/tns-2018-04
- https://access.redhat.com/errata/RHSA-2018:2185
- https://access.redhat.com/errata/RHSA-2018:2186
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
- https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
- https://security.FreeBSD.org/advisories/FreeBSD-SA-17:12.openssl.asc
- https://security.gentoo.org/glsa/201712-03
- http://www.securitytracker.com/id/1039978
- https://www.debian.org/security/2018/dsa-4157
- https://www.openssl.org/news/secadv/20171207.txt
- https://access.redhat.com/errata/RHSA-2018:0998
- http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
- https://github.com/openssl/openssl/commit/e502cc86df9dafded1694fceb3228ee34d11c11a
- https://www.tenable.com/security/tns-2018-06
- https://www.debian.org/security/2017/dsa-4065
- https://nodejs.org/en/blog/vulnerability/december-2017-security-releases/
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
- http://www.securityfocus.com/bid/102118
- https://www.tenable.com/security/tns-2017-16
- https://www.openssl.org/news/secadv/20180327.txt
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03881en_us
- https://nvd.nist.gov/vuln/detail/CVE-2017-3738