p PatchFirst

CVE-2017-3738

CVE-2017-3738

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

There is an overflow bug in the AVX2 Montgomery multiplication procedure used in exponentiation with 1024-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH1024 are considered just feasible, because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be significant. However, for an attack on TLS to be meaningful, the server would have to share the DH1024 private key among multiple clients, which is no longer an option since CVE-2016-0701. This only affects processors that support the AVX2 but not ADX extensions like Intel Haswell (4th generation). Note: The impact from this issue is similar to CVE-2017-3736, CVE-2017-3732 and CVE-2015-3193. OpenSSL version 1.0.2-1.0.2m and 1.1.0-1.1.0g are affected. Fixed in OpenSSL 1.0.2n. Due to the low severity of this issue we are not issuing a new release of OpenSSL 1.1.0 at this time. The fix will be included in OpenSSL 1.1.0h when it becomes available. The fix is also available in commit e502cc86d in the OpenSSL git repository.

CVSS 5.9 · Medium · EPSS 13.4% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • openssl

    Versions
    • 1.0.2-1.02m: Affected
    • 1.1.0-1.1.0g: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.1.0h-1

    Update to 1.1.0h-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.1.0h-1

    Update to 1.1.0h-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.1.0h-1

    Update to 1.1.0h-1

  • openssl Ubuntu:16.04:LTS

    Versions
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    Affected ranges
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.10

    Update to 1.0.2g-1ubuntu4.10

  • openssl Ubuntu:18.04:LTS

    Versions
    • 1.0.2g-1ubuntu13
    • 1.0.2g-1ubuntu14
    • 1.0.2n-1ubuntu1
    • 1.1.0g-2ubuntu1
    • 1.1.0g-2ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1.1.0g-2ubuntu3

    Update to 1.1.0g-2ubuntu3

Original sources

Check your server →