CVE-2018-1000077
CVE-2018-1000077
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.
CVSS 5.3 · Moyenne · EPSS 3,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
jruby Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 9.1.17.0-1
Mettez à jour vers 9.1.17.0-1
jruby Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 9.1.17.0-1
Mettez à jour vers 9.1.17.0-1
jruby Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 9.1.17.0-1
Mettez à jour vers 9.1.17.0-1
rubygems Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 3.2.0~rc.1-1
Mettez à jour vers 3.2.0~rc.1-1
rubygems Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.2.0~rc.1-1
Mettez à jour vers 3.2.0~rc.1-1
rubygems Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.2.0~rc.1-1
Mettez à jour vers 3.2.0~rc.1-1
ruby1.9.1 Ubuntu:14.04:LTS
- Versions du logiciel
- 1.9.3.194-8.1ubuntu2
- 1.9.3.448-1ubuntu1
- 1.9.3.448-1ubuntu2
- 1.9.3.484-1ubuntu1
- 1.9.3.484-1ubuntu2
- 1.9.3.484-2ubuntu1
- 1.9.3.484-2ubuntu1.1
- 1.9.3.484-2ubuntu1.2
- 1.9.3.484-2ubuntu1.3
- 1.9.3.484-2ubuntu1.5
- 1.9.3.484-2ubuntu1.6
- 1.9.3.484-2ubuntu1.7
- Plages de versions concernées
- ECOSYSTEM: < 1.9.3.484-2ubuntu1.8
Mettez à jour vers 1.9.3.484-2ubuntu1.8
ruby2.0 Ubuntu:14.04:LTS
- Versions du logiciel
- 2.0.0.299-2
- 2.0.0.343-1
- 2.0.0.343-1ubuntu1
- 2.0.0.353-1
- 2.0.0.353-1ubuntu1
- 2.0.0.484-1ubuntu1
- 2.0.0.484-1ubuntu2
- 2.0.0.484-1ubuntu2.1
- 2.0.0.484-1ubuntu2.2
- 2.0.0.484-1ubuntu2.4
- 2.0.0.484-1ubuntu2.5
- Plages de versions concernées
- ECOSYSTEM: < 2.0.0.484-1ubuntu2.6
Mettez à jour vers 2.0.0.484-1ubuntu2.6
jruby Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- Plages de versions concernées
- ECOSYSTEM: < 1.5.6-9+deb8u2build0.14.04.1~esm2
Mettez à jour vers 1.5.6-9+deb8u2build0.14.04.1~esm2
ruby2.3 Ubuntu:16.04:LTS
- Versions du logiciel
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- Plages de versions concernées
- ECOSYSTEM: < 2.3.1-2~16.04.7
Mettez à jour vers 2.3.1-2~16.04.7
jruby Ubuntu:16.04:LTS
- Versions du logiciel
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jruby Ubuntu:18.04:LTS
- Versions du logiciel
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://www.debian.org/security/2018/dsa-4219
- https://usn.ubuntu.com/3621-1/
- https://access.redhat.com/errata/RHSA-2018:3729
- https://access.redhat.com/errata/RHSA-2018:3730
- https://lists.debian.org/debian-lts-announce/2018/04/msg00023.html
- https://access.redhat.com/errata/RHSA-2018:3731
- https://lists.debian.org/debian-lts-announce/2018/04/msg00001.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://www.debian.org/security/2018/dsa-4259
- https://github.com/rubygems/rubygems/commit/feadefc2d351dcb95d6492f5ad17ebca546eb964
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html
- https://lists.debian.org/debian-lts-announce/2018/04/msg00000.html
- https://lists.debian.org/debian-lts-announce/2019/05/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://access.redhat.com/errata/RHSA-2019:2028
- https://access.redhat.com/errata/RHSA-2020:0542
- https://access.redhat.com/errata/RHSA-2020:0591
- https://access.redhat.com/errata/RHSA-2020:0663
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000077