CVE-2018-1000168
CVE-2018-1000168
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
CVSS 7.5 · Élevée · EPSS 10,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
nghttp2 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.31.1-1
Mettez à jour vers 1.31.1-1
nghttp2 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.31.1-1
Mettez à jour vers 1.31.1-1
nghttp2 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.31.1-1
Mettez à jour vers 1.31.1-1
nghttp2 Ubuntu:18.04:LTS
- Versions du logiciel
- 1.25.0-1
- 1.27.0-1
- 1.28.0-1
- 1.29.0-1
- 1.29.0-1build1
- 1.30.0-1
- Plages de versions concernées
- ECOSYSTEM: < 1.30.0-1ubuntu1
Mettez à jour vers 1.30.0-1ubuntu1
Sources originales
- https://access.redhat.com/errata/RHSA-2019:0367
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- http://www.securityfocus.com/bid/103952
- https://nghttp2.org/blog/2018/04/12/nghttp2-v1-31-1/
- https://access.redhat.com/errata/RHSA-2019:0366
- https://lists.debian.org/debian-lts-announce/2021/10/msg00011.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000168