CVE-2018-1000808
CVE-2018-1000808
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.
CVSS 8.2 · Élevée · EPSS 1,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
pyopenssl Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 17.5.0-1
Mettez à jour vers 17.5.0-1
pyopenssl Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 17.5.0-1
Mettez à jour vers 17.5.0-1
pyopenssl Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 17.5.0-1
Mettez à jour vers 17.5.0-1
pyopenssl PyPI
- Versions du logiciel
- 0.10
- 0.11
- 0.12
- 0.13
- 0.13.1
- 0.14
- 0.15
- 0.15.1
- 0.6
- 0.7
- 0.8
- 0.9
- 16.0.0
- 16.1.0
- 16.2.0
- 17.0.0
- 17.1.0
- 17.2.0
- 17.3.0
- 17.4.0
- Plages de versions concernées
- ECOSYSTEM: < 17.5.0
Mettez à jour vers 17.5.0
pyopenssl Ubuntu:16.04:LTS
- Versions du logiciel
- 0.15.1-2build1
- Plages de versions concernées
- ECOSYSTEM: < 0.15.1-2ubuntu0.2
Mettez à jour vers 0.15.1-2ubuntu0.2