p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de pyopenssl

Vulnérabilité publiée pour pyopenssl au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 5

  1. CVE-2026-27459

    Élevée · CVSS 7.2EPSS 0,73%Aucun correctif publié

    pyOpenSSL DTLS cookie callback buffer overflow

    pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 22.0.0 and prior to version 26.0.0, if a user provided callback to `set_cookie_generate_callback` returned a cookie value greater than 256 bytes, pyOpenSSL would overflow an OpenSSL provided buffer. Starting in version 26.0.0, cookie values that are too long are now rejected.

    Publication Mise à jour
  2. CVE-2026-27448

    Faible · CVSS 1.7EPSS 0,25%Aucun correctif publié

    pyOpenSSL allows TLS connection bypass via unhandled callback exception in set_tlsext_servername_callback

    pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 0.14.0 and prior to version 26.0.0, if a user provided callback to `set_tlsext_servername_callback` raised an unhandled exception, this would result in a connection being accepted. If a user was relying on this callback for any security-sensitive behavior, this could allow bypassing it. Starting in version 26.0.0, unhandled exceptions now result in rejecting the connection.

    Publication Mise à jour
  3. CVE-2018-1000808

    Élevée · CVSS 8.2EPSS 1,9%Correctif disponible

    CVE-2018-1000808

    Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.

    • Mettez à jour vers 17.5.0-1
    Publication Mise à jour
  4. CVE-2018-1000807

    Élevée · CVSS 8.1EPSS 4,08%Correctif disponible

    CVE-2018-1000807

    Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.

    • Mettez à jour vers 17.5.0-1
    Publication Mise à jour
  5. CVE-2013-4314

    Élevée · CVSS 8.7EPSS 1,2%Correctif disponible

    CVE-2013-4314

    The X509Extension in pyOpenSSL before 0.13.1 does not properly handle a '\0' character in a domain name in the Subject Alternative Name field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

    • Mettez à jour vers 0.13-2.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →