p PatchFirst

CVE-2019-20043

CVE-2019-20043

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

In in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in WordPress 3.7 to 5.3.0, authenticated users who do not have the rights to publish a post are able to mark posts as sticky or unsticky via the REST API. For example, the contributor role does not have such rights, but this allowed them to bypass that. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release.

CVSS 4.3 · Moyenne · EPSS 2,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Concernée

    Aucun correctif publié

  • wordpress Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Mettez à jour vers 5.3.2+dfsg1-1

  • wordpress Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Mettez à jour vers 5.3.2+dfsg1-1

  • wordpress Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Mettez à jour vers 5.3.2+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions du logiciel
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • wordpress Ubuntu:18.04:LTS

    Versions du logiciel
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →