CVE-2019-20043
CVE-2019-20043
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In in wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php in WordPress 3.7 to 5.3.0, authenticated users who do not have the rights to publish a post are able to mark posts as sticky or unsticky via the REST API. For example, the contributor role does not have such rights, but this allowed them to bypass that. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release.
CVSS 4.3 · Mittel · EPSS 2,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
n/a
- Softwareversionen
- n/a: Betroffen
Keine Korrektur veröffentlicht
wordpress Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.3.2+dfsg1-1
Auf 5.3.2+dfsg1-1 aktualisieren
wordpress Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.3.2+dfsg1-1
Auf 5.3.2+dfsg1-1 aktualisieren
wordpress Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.3.2+dfsg1-1
Auf 5.3.2+dfsg1-1 aktualisieren
wordpress Ubuntu:16.04:LTS
- Softwareversionen
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
wordpress Ubuntu:18.04:LTS
- Softwareversionen
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://wpvulndb.com/vulnerabilities/9973
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://core.trac.wordpress.org/changeset/46893/trunk
- https://github.com/WordPress/wordpress-develop/commit/1d1d5be7aa94608c04516cac4238e8c22b93c1d9
- https://seclists.org/bugtraq/2020/Jan/8
- https://www.debian.org/security/2020/dsa-4599
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-g7rg-hchx-c2gw
- https://www.debian.org/security/2020/dsa-4677
- https://nvd.nist.gov/vuln/detail/CVE-2019-20043