CVE-2020-4046
CVE-2020-4046 · Authenticated XSS through embed block in WordPress
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
In affected versions of WordPress, users with low privileges (like contributors and authors) can use the embed block in a certain way to inject unfiltered HTML in the block editor. When affected posts are viewed by a higher privileged user, this could lead to script execution in the editor/wp-admin. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
CVSS 5.4 · Moyenne · EPSS 2,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
wordpress-develop
- Versions du logiciel
- >= 5.4.0, < 5.4.2: Concernée
- >= 5.3.0, < 5.3.4: Concernée
- >= 5.2.0, < 5.2.7: Concernée
- >= 5.1.0, < 5.1.6: Concernée
- >= 5.0.0, < 5.0.10: Concernée
- >= 4.9.0, < 4.9.15: Concernée
- >= 4.8.0, < 4.8.14: Concernée
- >= 4.7.0, < 4.7.18: Concernée
- >= 4.6.0, < 4.6.19: Concernée
- >= 4.5.0, < 4.5.22: Concernée
- >= 4.4.0, < 4.4.23: Concernée
- >= 4.3.0, < 4.3.24: Concernée
- >= 4.2.0, < 4.2.28: Concernée
- >= 4.1.0, < 4.1.31: Concernée
- >= 4.0.0, < 4.0.31: Concernée
- >= 3.9.0, < 3.9.32: Concernée
- >= 3.8.0, < 3.8.34: Concernée
- >= 3.7.0, < 3.7.34: Concernée
Aucun correctif publié
wordpress Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.4.2+dfsg1-1
Mettez à jour vers 5.4.2+dfsg1-1
wordpress Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.4.2+dfsg1-1
Mettez à jour vers 5.4.2+dfsg1-1
wordpress Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.4.2+dfsg1-1
Mettez à jour vers 5.4.2+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions du logiciel
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:18.04:LTS
- Versions du logiciel
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:20.04:LTS
- Versions du logiciel
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:22.04:LTS
- Versions du logiciel
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-rpwf-hrh2-39jf
- https://wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ODNHXVJS25YVWYQHOCICXTLIN5UYJFDN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/773N2ZV7QEMBGKH6FBKI6Q5S3YJMW357/
- https://www.debian.org/security/2020/dsa-4709
- https://lists.debian.org/debian-lts-announce/2020/07/msg00000.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-4046