CVE-2020-4046
CVE-2020-4046 · Authenticated XSS through embed block in WordPress
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In affected versions of WordPress, users with low privileges (like contributors and authors) can use the embed block in a certain way to inject unfiltered HTML in the block editor. When affected posts are viewed by a higher privileged user, this could lead to script execution in the editor/wp-admin. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
CVSS 5.4 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress-develop
- Versions
- >= 5.4.0, < 5.4.2: Affected
- >= 5.3.0, < 5.3.4: Affected
- >= 5.2.0, < 5.2.7: Affected
- >= 5.1.0, < 5.1.6: Affected
- >= 5.0.0, < 5.0.10: Affected
- >= 4.9.0, < 4.9.15: Affected
- >= 4.8.0, < 4.8.14: Affected
- >= 4.7.0, < 4.7.18: Affected
- >= 4.6.0, < 4.6.19: Affected
- >= 4.5.0, < 4.5.22: Affected
- >= 4.4.0, < 4.4.23: Affected
- >= 4.3.0, < 4.3.24: Affected
- >= 4.2.0, < 4.2.28: Affected
- >= 4.1.0, < 4.1.31: Affected
- >= 4.0.0, < 4.0.31: Affected
- >= 3.9.0, < 3.9.32: Affected
- >= 3.8.0, < 3.8.34: Affected
- >= 3.7.0, < 3.7.34: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.4.2+dfsg1-1
Update to 5.4.2+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.4.2+dfsg1-1
Update to 5.4.2+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.4.2+dfsg1-1
Update to 5.4.2+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-rpwf-hrh2-39jf
- https://wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ODNHXVJS25YVWYQHOCICXTLIN5UYJFDN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/773N2ZV7QEMBGKH6FBKI6Q5S3YJMW357/
- https://www.debian.org/security/2020/dsa-4709
- https://lists.debian.org/debian-lts-announce/2020/07/msg00000.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-4046