CVE-2021-31566
CVE-2021-31566
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
An improper link resolution flaw can occur while extracting an archive leading to changing modes, times, access control lists, and flags of a file outside of the archive. An attacker may provide a malicious archive to a victim user, who would trigger this flaw when trying to extract the archive. A local attacker may use this flaw to gain more privileges in a system.
CVSS 7.8 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libarchive
- Versions du logiciel
- Fixed in libarchive 3.5.2: Concernée
Aucun correctif publié
libarchive Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 3.5.2-1
Mettez à jour vers 3.5.2-1
libarchive Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.5.2-1
Mettez à jour vers 3.5.2-1
libarchive Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.5.2-1
Mettez à jour vers 3.5.2-1
libarchive Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 3.1.2-5ubuntu1
- 3.1.2-7ubuntu1
- 3.1.2-7ubuntu2
- 3.1.2-7ubuntu2.1
- 3.1.2-7ubuntu2.2
- 3.1.2-7ubuntu2.3
- 3.1.2-7ubuntu2.4
- 3.1.2-7ubuntu2.6
- 3.1.2-7ubuntu2.7
- 3.1.2-7ubuntu2.8
- 3.1.2-7ubuntu2.8+esm1
- 3.1.2-7ubuntu2.8+esm3
- 3.1.2-7ubuntu2.8+esm4
- 3.1.2-7ubuntu2.8+esm5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libarchive Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 3.1.2-11build1
- 3.1.2-11ubuntu0.16.04.1
- 3.1.2-11ubuntu0.16.04.2
- 3.1.2-11ubuntu0.16.04.3
- 3.1.2-11ubuntu0.16.04.4
- 3.1.2-11ubuntu0.16.04.5
- 3.1.2-11ubuntu0.16.04.6
- 3.1.2-11ubuntu0.16.04.7
- 3.1.2-11ubuntu0.16.04.8
- 3.1.2-11ubuntu0.16.04.8+esm1
- 3.1.2-11ubuntu0.16.04.8+esm2
- 3.1.2-11ubuntu0.16.04.8+esm3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libarchive Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 3.2.2-3.1
- 3.2.2-3.1ubuntu0.1
- 3.2.2-3.1ubuntu0.2
- 3.2.2-3.1ubuntu0.3
- 3.2.2-3.1ubuntu0.4
- 3.2.2-3.1ubuntu0.5
- 3.2.2-3.1ubuntu0.6
- 3.2.2-3.1ubuntu0.7
- 3.2.2-3.1ubuntu0.7+esm1
- 3.2.2-3.1ubuntu0.7+esm2
- 3.2.2-3.1ubuntu0.7+esm3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libarchive Ubuntu:20.04:LTS
- Versions du logiciel
- 3.4.0-1
- 3.4.0-1build1
- 3.4.0-1ubuntu2
- 3.4.0-2ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 3.4.0-2ubuntu1.1
Mettez à jour vers 3.4.0-2ubuntu1.1
Sources originales
- https://github.com/libarchive/libarchive/issues/1566
- https://github.com/libarchive/libarchive/commit/b41daecb5ccb4c8e3b2c53fd6147109fc12c3043
- https://bugzilla.redhat.com/show_bug.cgi?id=2024237
- https://access.redhat.com/security/cve/CVE-2021-31566
- https://lists.debian.org/debian-lts-announce/2022/11/msg00030.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-31566