p PatchFirst

CVE-2021-31566

CVE-2021-31566

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

An improper link resolution flaw can occur while extracting an archive leading to changing modes, times, access control lists, and flags of a file outside of the archive. An attacker may provide a malicious archive to a victim user, who would trigger this flaw when trying to extract the archive. A local attacker may use this flaw to gain more privileges in a system.

CVSS 7.8 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • libarchive

    Softwareversionen
    • Fixed in libarchive 3.5.2: Betroffen

    Keine Korrektur veröffentlicht

  • libarchive Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.2-1

    Auf 3.5.2-1 aktualisieren

  • libarchive Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.2-1

    Auf 3.5.2-1 aktualisieren

  • libarchive Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.5.2-1

    Auf 3.5.2-1 aktualisieren

  • libarchive Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 3.1.2-5ubuntu1
    • 3.1.2-7ubuntu1
    • 3.1.2-7ubuntu2
    • 3.1.2-7ubuntu2.1
    • 3.1.2-7ubuntu2.2
    • 3.1.2-7ubuntu2.3
    • 3.1.2-7ubuntu2.4
    • 3.1.2-7ubuntu2.6
    • 3.1.2-7ubuntu2.7
    • 3.1.2-7ubuntu2.8
    • 3.1.2-7ubuntu2.8+esm1
    • 3.1.2-7ubuntu2.8+esm3
    • 3.1.2-7ubuntu2.8+esm4
    • 3.1.2-7ubuntu2.8+esm5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libarchive Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 3.1.2-11build1
    • 3.1.2-11ubuntu0.16.04.1
    • 3.1.2-11ubuntu0.16.04.2
    • 3.1.2-11ubuntu0.16.04.3
    • 3.1.2-11ubuntu0.16.04.4
    • 3.1.2-11ubuntu0.16.04.5
    • 3.1.2-11ubuntu0.16.04.6
    • 3.1.2-11ubuntu0.16.04.7
    • 3.1.2-11ubuntu0.16.04.8
    • 3.1.2-11ubuntu0.16.04.8+esm1
    • 3.1.2-11ubuntu0.16.04.8+esm2
    • 3.1.2-11ubuntu0.16.04.8+esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libarchive Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.2.2-3.1
    • 3.2.2-3.1ubuntu0.1
    • 3.2.2-3.1ubuntu0.2
    • 3.2.2-3.1ubuntu0.3
    • 3.2.2-3.1ubuntu0.4
    • 3.2.2-3.1ubuntu0.5
    • 3.2.2-3.1ubuntu0.6
    • 3.2.2-3.1ubuntu0.7
    • 3.2.2-3.1ubuntu0.7+esm1
    • 3.2.2-3.1ubuntu0.7+esm2
    • 3.2.2-3.1ubuntu0.7+esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libarchive Ubuntu:20.04:LTS

    Softwareversionen
    • 3.4.0-1
    • 3.4.0-1build1
    • 3.4.0-1ubuntu2
    • 3.4.0-2ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.0-2ubuntu1.1

    Auf 3.4.0-2ubuntu1.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →