CVE-2021-32702
CVE-2021-32702 · Reflected XSS from the callback handler's error query parameter
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
CVSS 8.0 · Élevée · EPSS 1,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
nextjs-auth0
- Versions du logiciel
- < 1.4.2: Concernée
Aucun correctif publié
@auth0/nextjs-auth0 npm
- Plages de versions concernées
- SEMVER: < 1.4.2
Mettez à jour vers 1.4.2