p PatchFirst

CVE-2021-32702

CVE-2021-32702 · Reflected XSS from the callback handler's error query parameter

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.

CVSS 8.0 · Hoch · EPSS 1,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • nextjs-auth0

    Softwareversionen
    • < 1.4.2: Betroffen

    Keine Korrektur veröffentlicht

  • @auth0/nextjs-auth0 npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.4.2

    Auf 1.4.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →