CVE-2021-32719
CVE-2021-32719 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ federation management plugin
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the `rabbitmq_federation_management` plugin, its consumer tag was rendered without proper <script> tag sanitization. This potentially allows for JavaScript code execution in the context of the page. The user must be signed in and have elevated permissions (manage federation upstreams and policies) for this to occur. The vulnerability is patched in RabbitMQ 3.8.18. As a workaround, disable the `rabbitmq_federation_management` plugin and use [CLI tools](https://www.rabbitmq.com/cli.html) instead.
CVSS 3.1 · Faible · EPSS 1,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · database
Produits et versions concernés
rabbitmq
- Versions du logiciel
- < 3.8.18: Concernée
Aucun correctif publié
rabbitmq-server Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 3.9.4-1
Mettez à jour vers 3.9.4-1
rabbitmq-server Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.9.4-1
Mettez à jour vers 3.9.4-1
rabbitmq-server Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.9.4-1
Mettez à jour vers 3.9.4-1
rabbitmq-server Ubuntu:20.04:LTS
- Versions du logiciel
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 3.8.3-0ubuntu0.2
Mettez à jour vers 3.8.3-0ubuntu0.2