p PatchFirst

CVE-2021-32719

CVE-2021-32719 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in RabbitMQ federation management plugin

This page contains facts from public vulnerability sources. Check the original advisory before updating.

RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the `rabbitmq_federation_management` plugin, its consumer tag was rendered without proper <script> tag sanitization. This potentially allows for JavaScript code execution in the context of the page. The user must be signed in and have elevated permissions (manage federation upstreams and policies) for this to occur. The vulnerability is patched in RabbitMQ 3.8.18. As a workaround, disable the `rabbitmq_federation_management` plugin and use [CLI tools](https://www.rabbitmq.com/cli.html) instead.

CVSS 3.1 · Low · EPSS 1.4% · Fix available

Published
Updated

Stack: system · database

Affected products and versions

  • rabbitmq

    Versions
    • < 3.8.18: Affected

    No fix published

  • rabbitmq-server Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.9.4-1

    Update to 3.9.4-1

  • rabbitmq-server Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.9.4-1

    Update to 3.9.4-1

  • rabbitmq-server Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.9.4-1

    Update to 3.9.4-1

  • rabbitmq-server Ubuntu:20.04:LTS

    Versions
    • 3.7.8-4ubuntu2
    • 3.7.18-1
    • 3.8.2-0ubuntu1
    • 3.8.2-0ubuntu1.1
    • 3.8.2-0ubuntu1.2
    • 3.8.2-0ubuntu1.3
    • 3.8.2-0ubuntu1.4
    • 3.8.2-0ubuntu1.5
    • 3.8.3-0ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 3.8.3-0ubuntu0.2

    Update to 3.8.3-0ubuntu0.2

Original sources

Check your server →