p PatchFirst

CVE-2021-3667

CVE-2021-3667

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

An improper locking issue was found in the virStoragePoolLookupByTargetPath API of libvirt. It occurs in the storagePoolLookupByTargetPath function where a locked virStoragePoolObj object is not properly released on ACL permission failure. Clients connecting to the read-write socket with limited ACL permissions could use this flaw to acquire the lock and prevent other users from accessing storage pool/volume APIs, resulting in a denial of service condition. The highest threat from this vulnerability is to system availability.

CVSS 6.5 · Moyenne · EPSS 1,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • libvirt

    Versions du logiciel
    • Fixedin - libvert v7.6.0-rc1 and above: Concernée

    Aucun correctif publié

  • libvirt Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 7.6.0-1

    Mettez à jour vers 7.6.0-1

  • libvirt Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 7.6.0-1

    Mettez à jour vers 7.6.0-1

  • libvirt Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 7.6.0-1

    Mettez à jour vers 7.6.0-1

  • libvirt Ubuntu:20.04:LTS

    Versions du logiciel
    • 5.4.0-0ubuntu5
    • 6.0.0-0ubuntu1
    • 6.0.0-0ubuntu2
    • 6.0.0-0ubuntu3
    • 6.0.0-0ubuntu4
    • 6.0.0-0ubuntu5
    • 6.0.0-0ubuntu6
    • 6.0.0-0ubuntu7
    • 6.0.0-0ubuntu8
    • 6.0.0-0ubuntu8.1
    • 6.0.0-0ubuntu8.2
    • 6.0.0-0ubuntu8.3
    • 6.0.0-0ubuntu8.4
    • 6.0.0-0ubuntu8.5
    • 6.0.0-0ubuntu8.7
    • 6.0.0-0ubuntu8.8
    • 6.0.0-0ubuntu8.9
    • 6.0.0-0ubuntu8.10
    • 6.0.0-0ubuntu8.11
    • 6.0.0-0ubuntu8.12
    • 6.0.0-0ubuntu8.13
    • 6.0.0-0ubuntu8.14
    • 6.0.0-0ubuntu8.15
    Plages de versions concernées
    • ECOSYSTEM: < 6.0.0-0ubuntu8.16

    Mettez à jour vers 6.0.0-0ubuntu8.16

  • libvirt Ubuntu:22.04:LTS

    Versions du logiciel
    • 7.6.0-0ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: < 7.6.0-0ubuntu3

    Mettez à jour vers 7.6.0-0ubuntu3

Sources originales

Vérifiez votre serveur →