p PatchFirst

CVE-2021-3667

CVE-2021-3667

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

An improper locking issue was found in the virStoragePoolLookupByTargetPath API of libvirt. It occurs in the storagePoolLookupByTargetPath function where a locked virStoragePoolObj object is not properly released on ACL permission failure. Clients connecting to the read-write socket with limited ACL permissions could use this flaw to acquire the lock and prevent other users from accessing storage pool/volume APIs, resulting in a denial of service condition. The highest threat from this vulnerability is to system availability.

CVSS 6.5 · Mittel · EPSS 1,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • libvirt

    Softwareversionen
    • Fixedin - libvert v7.6.0-rc1 and above: Betroffen

    Keine Korrektur veröffentlicht

  • libvirt Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.6.0-1

    Auf 7.6.0-1 aktualisieren

  • libvirt Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.6.0-1

    Auf 7.6.0-1 aktualisieren

  • libvirt Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.6.0-1

    Auf 7.6.0-1 aktualisieren

  • libvirt Ubuntu:20.04:LTS

    Softwareversionen
    • 5.4.0-0ubuntu5
    • 6.0.0-0ubuntu1
    • 6.0.0-0ubuntu2
    • 6.0.0-0ubuntu3
    • 6.0.0-0ubuntu4
    • 6.0.0-0ubuntu5
    • 6.0.0-0ubuntu6
    • 6.0.0-0ubuntu7
    • 6.0.0-0ubuntu8
    • 6.0.0-0ubuntu8.1
    • 6.0.0-0ubuntu8.2
    • 6.0.0-0ubuntu8.3
    • 6.0.0-0ubuntu8.4
    • 6.0.0-0ubuntu8.5
    • 6.0.0-0ubuntu8.7
    • 6.0.0-0ubuntu8.8
    • 6.0.0-0ubuntu8.9
    • 6.0.0-0ubuntu8.10
    • 6.0.0-0ubuntu8.11
    • 6.0.0-0ubuntu8.12
    • 6.0.0-0ubuntu8.13
    • 6.0.0-0ubuntu8.14
    • 6.0.0-0ubuntu8.15
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.0.0-0ubuntu8.16

    Auf 6.0.0-0ubuntu8.16 aktualisieren

  • libvirt Ubuntu:22.04:LTS

    Softwareversionen
    • 7.6.0-0ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.6.0-0ubuntu3

    Auf 7.6.0-0ubuntu3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →