CVE-2021-4209
CVE-2021-4209
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A NULL pointer dereference flaw was found in GnuTLS. As Nettle's hash update functions internally call memcpy, providing zero-length input may cause undefined behavior. This flaw leads to a denial of service after authentication in rare circumstances.
CVSS 6.5 · Moyenne · EPSS 1,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
gnutls
- Versions du logiciel
- Fixed in gnutls v3.7.3: Concernée
Aucun correctif publié
gnutls28 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 3.7.3-2
Mettez à jour vers 3.7.3-2
gnutls28 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.7.3-2
Mettez à jour vers 3.7.3-2
gnutls28 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.7.3-2
Mettez à jour vers 3.7.3-2
gnutls26 Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 2.12.23-1ubuntu4
- 2.12.23-1ubuntu5
- 2.12.23-12ubuntu1
- 2.12.23-12ubuntu2
- 2.12.23-12ubuntu2.1
- 2.12.23-12ubuntu2.2
- 2.12.23-12ubuntu2.3
- 2.12.23-12ubuntu2.4
- 2.12.23-12ubuntu2.5
- 2.12.23-12ubuntu2.6
- 2.12.23-12ubuntu2.7
- 2.12.23-12ubuntu2.8
- 2.12.23-12ubuntu2.10+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
gnutls28 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 3.3.15-5ubuntu2
- 3.3.18-1ubuntu1
- 3.3.20-1ubuntu1
- 3.4.9-2ubuntu1
- 3.4.10-4ubuntu1
- 3.4.10-4ubuntu1.1
- 3.4.10-4ubuntu1.2
- 3.4.10-4ubuntu1.3
- 3.4.10-4ubuntu1.4
- 3.4.10-4ubuntu1.5
- 3.4.10-4ubuntu1.6
- 3.4.10-4ubuntu1.7
- 3.4.10-4ubuntu1.8
- 3.4.10-4ubuntu1.9
- Plages de versions concernées
- ECOSYSTEM: < 3.4.10-4ubuntu1.9+esm1
Mettez à jour vers 3.4.10-4ubuntu1.9+esm1
gnutls28 Ubuntu:18.04:LTS
- Versions du logiciel
- 3.5.8-6ubuntu3
- 3.5.17-1ubuntu1
- 3.5.17-1ubuntu3
- 3.5.18-1ubuntu1
- 3.5.18-1ubuntu1.1
- 3.5.18-1ubuntu1.2
- 3.5.18-1ubuntu1.3
- 3.5.18-1ubuntu1.4
- 3.5.18-1ubuntu1.5
- Plages de versions concernées
- ECOSYSTEM: < 3.5.18-1ubuntu1.6
Mettez à jour vers 3.5.18-1ubuntu1.6
gnutls28 Ubuntu:20.04:LTS
- Versions du logiciel
- 3.6.9-5ubuntu1
- 3.6.9-5ubuntu2
- 3.6.10-5
- 3.6.11.1-2
- 3.6.11.1-2ubuntu2
- 3.6.13-2ubuntu1
- 3.6.13-2ubuntu1.1
- 3.6.13-2ubuntu1.2
- 3.6.13-2ubuntu1.3
- 3.6.13-2ubuntu1.6
- Plages de versions concernées
- ECOSYSTEM: < 3.6.13-2ubuntu1.7
Mettez à jour vers 3.6.13-2ubuntu1.7
Sources originales
- https://gitlab.com/gnutls/gnutls/-/issues/1306
- https://bugzilla.redhat.com/show_bug.cgi?id=2044156
- https://access.redhat.com/security/cve/CVE-2021-4209
- https://gitlab.com/gnutls/gnutls/-/merge_requests/1503
- https://gitlab.com/gnutls/gnutls/-/commit/3db352734472d851318944db13be73da61300568
- https://security.netapp.com/advisory/ntap-20220915-0005/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-4209