p PatchFirst

CVE-2021-4209

CVE-2021-4209

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A NULL pointer dereference flaw was found in GnuTLS. As Nettle's hash update functions internally call memcpy, providing zero-length input may cause undefined behavior. This flaw leads to a denial of service after authentication in rare circumstances.

CVSS 6.5 · Medium · EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gnutls

    Versions
    • Fixed in gnutls v3.7.3: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.7.3-2

    Update to 3.7.3-2

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.7.3-2

    Update to 3.7.3-2

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.7.3-2

    Update to 3.7.3-2

  • gnutls26 Ubuntu:Pro:14.04:LTS

    Versions
    • 2.12.23-1ubuntu4
    • 2.12.23-1ubuntu5
    • 2.12.23-12ubuntu1
    • 2.12.23-12ubuntu2
    • 2.12.23-12ubuntu2.1
    • 2.12.23-12ubuntu2.2
    • 2.12.23-12ubuntu2.3
    • 2.12.23-12ubuntu2.4
    • 2.12.23-12ubuntu2.5
    • 2.12.23-12ubuntu2.6
    • 2.12.23-12ubuntu2.7
    • 2.12.23-12ubuntu2.8
    • 2.12.23-12ubuntu2.10+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gnutls28 Ubuntu:Pro:16.04:LTS

    Versions
    • 3.3.15-5ubuntu2
    • 3.3.18-1ubuntu1
    • 3.3.20-1ubuntu1
    • 3.4.9-2ubuntu1
    • 3.4.10-4ubuntu1
    • 3.4.10-4ubuntu1.1
    • 3.4.10-4ubuntu1.2
    • 3.4.10-4ubuntu1.3
    • 3.4.10-4ubuntu1.4
    • 3.4.10-4ubuntu1.5
    • 3.4.10-4ubuntu1.6
    • 3.4.10-4ubuntu1.7
    • 3.4.10-4ubuntu1.8
    • 3.4.10-4ubuntu1.9
    Affected ranges
    • ECOSYSTEM: < 3.4.10-4ubuntu1.9+esm1

    Update to 3.4.10-4ubuntu1.9+esm1

  • gnutls28 Ubuntu:18.04:LTS

    Versions
    • 3.5.8-6ubuntu3
    • 3.5.17-1ubuntu1
    • 3.5.17-1ubuntu3
    • 3.5.18-1ubuntu1
    • 3.5.18-1ubuntu1.1
    • 3.5.18-1ubuntu1.2
    • 3.5.18-1ubuntu1.3
    • 3.5.18-1ubuntu1.4
    • 3.5.18-1ubuntu1.5
    Affected ranges
    • ECOSYSTEM: < 3.5.18-1ubuntu1.6

    Update to 3.5.18-1ubuntu1.6

  • gnutls28 Ubuntu:20.04:LTS

    Versions
    • 3.6.9-5ubuntu1
    • 3.6.9-5ubuntu2
    • 3.6.10-5
    • 3.6.11.1-2
    • 3.6.11.1-2ubuntu2
    • 3.6.13-2ubuntu1
    • 3.6.13-2ubuntu1.1
    • 3.6.13-2ubuntu1.2
    • 3.6.13-2ubuntu1.3
    • 3.6.13-2ubuntu1.6
    Affected ranges
    • ECOSYSTEM: < 3.6.13-2ubuntu1.7

    Update to 3.6.13-2ubuntu1.7

Original sources

Check your server →