CVE-2022-1271
CVE-2022-1271
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
An arbitrary file write vulnerability was found in GNU gzip's zgrep utility. When zgrep is applied on the attacker's chosen file name (for example, a crafted file name), this can overwrite an attacker's content to an arbitrary attacker-selected file. This flaw occurs due to insufficient validation when processing filenames with two or more newlines where selected content and the target file names are embedded in crafted multi-line file names. This flaw allows a remote, low privileged attacker to force zgrep to write arbitrary files on the system.
CVSS 8.8 · Élevée · EPSS 5,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
gzip, xz-utils
- Versions du logiciel
- Fixed in gzip 1.12: Concernée
Aucun correctif publié
gzip Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.12-1
Mettez à jour vers 1.12-1
gzip Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.12-1
Mettez à jour vers 1.12-1
gzip Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.12-1
Mettez à jour vers 1.12-1
xz-utils Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.2.5-2.1
Mettez à jour vers 5.2.5-2.1
xz-utils Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.2.5-2.1
Mettez à jour vers 5.2.5-2.1
xz-utils Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.2.5-2.1
Mettez à jour vers 5.2.5-2.1
gzip Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.6-2ubuntu1
- 1.6-3ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 1.6-3ubuntu1+esm1
Mettez à jour vers 1.6-3ubuntu1+esm1
xz-utils Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 5.1.1alpha+20120614-2ubuntu1
- 5.1.1alpha+20120614-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1
Mettez à jour vers 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1
gzip Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6-4ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 1.6-4ubuntu1+esm1
Mettez à jour vers 1.6-4ubuntu1+esm1
xz-utils Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 5.1.1alpha+20120614-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1
Mettez à jour vers 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1
gzip Ubuntu:18.04:LTS
- Versions du logiciel
- 1.6-5ubuntu1
- 1.6-5ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6-5ubuntu1.2
Mettez à jour vers 1.6-5ubuntu1.2
xz-utils Ubuntu:18.04:LTS
- Versions du logiciel
- 5.2.2-1.3
- Plages de versions concernées
- ECOSYSTEM: < 5.2.2-1.3ubuntu0.1
Mettez à jour vers 5.2.2-1.3ubuntu0.1
gzip Ubuntu:20.04:LTS
- Versions du logiciel
- 1.10-0ubuntu3
- 1.10-0ubuntu4
- Plages de versions concernées
- ECOSYSTEM: < 1.10-0ubuntu4.1
Mettez à jour vers 1.10-0ubuntu4.1
xz-utils Ubuntu:20.04:LTS
- Versions du logiciel
- 5.2.4-1
- 5.2.4-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 5.2.4-1ubuntu1.1
Mettez à jour vers 5.2.4-1ubuntu1.1
gzip Ubuntu:22.04:LTS
- Versions du logiciel
- 1.10-4ubuntu1
- 1.10-4ubuntu2
- 1.10-4ubuntu3
- Plages de versions concernées
- ECOSYSTEM: < 1.10-4ubuntu4
Mettez à jour vers 1.10-4ubuntu4
xz-utils Ubuntu:22.04:LTS
- Versions du logiciel
- 5.2.5-2
- 5.2.5-2build1
- 5.2.5-2build2
- Plages de versions concernées
- ECOSYSTEM: < 5.2.5-2ubuntu1
Mettez à jour vers 5.2.5-2ubuntu1
Sources originales
- https://bugzilla.redhat.com/show_bug.cgi?id=2073310
- https://www.openwall.com/lists/oss-security/2022/04/07/8
- https://lists.gnu.org/r/bug-gzip/2022-04/msg00011.html
- https://tukaani.org/xz/xzgrep-ZDI-CAN-16587.patch
- https://git.tukaani.org/?p=xz.git%3Ba=commit%3Bh=69d1b3fc29677af8ade8dc15dba83f0589cb63d6
- https://security-tracker.debian.org/tracker/CVE-2022-1271
- https://access.redhat.com/security/cve/CVE-2022-1271
- https://security.gentoo.org/glsa/202209-01
- https://security.netapp.com/advisory/ntap-20220930-0006/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-455250.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-1271