p PatchFirst

CVE-2022-1271

CVE-2022-1271

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

An arbitrary file write vulnerability was found in GNU gzip's zgrep utility. When zgrep is applied on the attacker's chosen file name (for example, a crafted file name), this can overwrite an attacker's content to an arbitrary attacker-selected file. This flaw occurs due to insufficient validation when processing filenames with two or more newlines where selected content and the target file names are embedded in crafted multi-line file names. This flaw allows a remote, low privileged attacker to force zgrep to write arbitrary files on the system.

CVSS 8.8 · Hoch · EPSS 5,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • gzip, xz-utils

    Softwareversionen
    • Fixed in gzip 1.12: Betroffen

    Keine Korrektur veröffentlicht

  • gzip Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.12-1

    Auf 1.12-1 aktualisieren

  • gzip Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.12-1

    Auf 1.12-1 aktualisieren

  • gzip Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.12-1

    Auf 1.12-1 aktualisieren

  • xz-utils Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.5-2.1

    Auf 5.2.5-2.1 aktualisieren

  • xz-utils Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.5-2.1

    Auf 5.2.5-2.1 aktualisieren

  • xz-utils Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.5-2.1

    Auf 5.2.5-2.1 aktualisieren

  • gzip Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1.6-2ubuntu1
    • 1.6-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6-3ubuntu1+esm1

    Auf 1.6-3ubuntu1+esm1 aktualisieren

  • xz-utils Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 5.1.1alpha+20120614-2ubuntu1
    • 5.1.1alpha+20120614-2ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1

    Auf 5.1.1alpha+20120614-2ubuntu2.14.04.1+esm1 aktualisieren

  • gzip Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.6-4ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6-4ubuntu1+esm1

    Auf 1.6-4ubuntu1+esm1 aktualisieren

  • xz-utils Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 5.1.1alpha+20120614-2ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1

    Auf 5.1.1alpha+20120614-2ubuntu2.16.04.1+esm1 aktualisieren

  • gzip Ubuntu:18.04:LTS

    Softwareversionen
    • 1.6-5ubuntu1
    • 1.6-5ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6-5ubuntu1.2

    Auf 1.6-5ubuntu1.2 aktualisieren

  • xz-utils Ubuntu:18.04:LTS

    Softwareversionen
    • 5.2.2-1.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.2-1.3ubuntu0.1

    Auf 5.2.2-1.3ubuntu0.1 aktualisieren

  • gzip Ubuntu:20.04:LTS

    Softwareversionen
    • 1.10-0ubuntu3
    • 1.10-0ubuntu4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.10-0ubuntu4.1

    Auf 1.10-0ubuntu4.1 aktualisieren

  • xz-utils Ubuntu:20.04:LTS

    Softwareversionen
    • 5.2.4-1
    • 5.2.4-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.4-1ubuntu1.1

    Auf 5.2.4-1ubuntu1.1 aktualisieren

  • gzip Ubuntu:22.04:LTS

    Softwareversionen
    • 1.10-4ubuntu1
    • 1.10-4ubuntu2
    • 1.10-4ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.10-4ubuntu4

    Auf 1.10-4ubuntu4 aktualisieren

  • xz-utils Ubuntu:22.04:LTS

    Softwareversionen
    • 5.2.5-2
    • 5.2.5-2build1
    • 5.2.5-2build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.2.5-2ubuntu1

    Auf 5.2.5-2ubuntu1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →